Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-3033

Course module id incorrect when marking discussion as read

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE

      Description

      When clicking on the eye icon for marking a discussion as read in forums on moodle.org I occasionally get course module id incorrect error. Recent example:

      http://moodle.org/mod/forum/view.php?id=5&f=15

      Note: it seems that after messages are marked unread, I am sent to an incorrect url. [The discussion forum in question was #28: Installation Problems.]

        Gliffy Diagrams

          Activity

          dougiamas Martin Dougiamas added a comment -

          From Martin Dougiamas (martin at moodle.com) Tuesday, 26 April 2005, 09:42 AM:

          Is this fixed now? I didn't see this bug before but I did some work on the code last night. I can't duplicate the problem ...

          From Zbigniew Fiedorowicz (fiedorow at math.ohio-state.edu) Tuesday, 26 April 2005, 11:23 AM:

          I haven't seen this since.

          This happened just minutes before the mark unread icon was changed from an eye to a checkmark. As I recall, this error happened twice when marking unread discussions in the installation problems forum and both discussions which caused this error were started by Dallas Ray Smetter.

          From Zbigniew Fiedorowicz (fiedorow at math.ohio-state.edu) Thursday, 28 April 2005, 12:34 AM:

          Nope, it's still around. Today I ran into this twice in the General Problems Forum.

          Details:

          http://moodle.org/mod/forum/markposts.php?id=32&d=21912&mark=read&returnpage=view.php

          returned me to:

          http://moodle.org/mod/forum/view.php?id=5&f=32

          From Zbigniew Fiedorowicz (fiedorow at math.ohio-state.edu) Thursday, 28 April 2005, 12:50 AM:

          OK, I think I can reproduce this reliably.

          1) Open a forum with several unread discussions.

          2) Right click on a Mark Unread checkmark so as to open in a new window

          3) Close the new window.

          4) Right click again on the SAME checkmark as in Step 2, again opening in a new window.

          5) You get a correct error message that the discussion could not be marked unread. Close this window again

          6) Return to previous window and right click on some OTHER Mark Unread checkmark.

          7) You will now get sent to a bad url and precipitate the error message.

          8) If you return to the first window, and continue doing this, this bug will repeat, until you refresh the window.

          From Zbigniew Fiedorowicz (fiedorow at math.ohio-state.edu) Thursday, 28 April 2005, 05:26 AM:

          Seems to be due to a typo in markposts.php

          Should be fixed now.

          From Mike Churchward (mike at churchward.ca) Friday, 29 April 2005, 03:38 AM:

          Hmmm. I don't think the fix is quite correct. The markposts doesn't work from the forum index page. The 'id' argument in the 'returnto' parameter is supposed to be the course id. Its been changed to the course module id to work with the 'view' page.

          I will rework this to use explicit arguments:

          id = course id,

          cm = cm id,

          f = forum id,

          d = discussion id.

          From Mike Churchward (mike at churchward.ca) Friday, 29 April 2005, 03:49 AM:

          Fixed. Specifically used 'f=' for forums and 'd=' for dicussions. Checked the return page and set up proper arguments based on page.

          From Eloy Lafuente (stronk7 at moodle.org) Monday, 6 June 2005, 03:19 AM:

          Hi Mike and Fied,

          can this be closed then?

          From Mike Churchward (mike at churchward.ca) Tuesday, 7 June 2005, 01:01 AM:

          I believe so. Fied?

          From Zbigniew Fiedorowicz (fiedorow at math.ohio-state.edu) Tuesday, 7 June 2005, 02:20 AM:

          Yes, I'm closing it.

          mblake Michael Blake added a comment -

          assign to a valid user


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: