Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30368

Bug on export to portfolio through student's forum post

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • 2.2
    • 2.2
    • Forum, Portfolio
    • MOODLE_22_STABLE
    • MOODLE_22_STABLE
    • Hide

      This test requires the following:

      Portfolios and the Box.net, Flickr and Picasa portfolio plugins enabled for the site
      A forum activity containing a post by a student with an image attached
      Box.net, Flickr and Picasa accounts for use in testing
      1. Login as the student and access the forum post.
      2. Try exporting the post, selecting Box.net as the portfolio.
      3. Check that both the post and attachment are exported correctly to Box.net.
      4. Try exporting the attachment, selecting Flickr as the portfolio.
      5. Check that the image is exported correctly to Flickr.
      6. Try exporting the attachment again, selecting Picasa as the portfolio.
      7. Check that the image is exported correctly to Picasa.

      Show
      This test requires the following: Portfolios and the Box.net, Flickr and Picasa portfolio plugins enabled for the site A forum activity containing a post by a student with an image attached Box.net, Flickr and Picasa accounts for use in testing 1. Login as the student and access the forum post. 2. Try exporting the post, selecting Box.net as the portfolio. 3. Check that both the post and attachment are exported correctly to Box.net. 4. Try exporting the attachment, selecting Flickr as the portfolio. 5. Check that the image is exported correctly to Flickr. 6. Try exporting the attachment again, selecting Picasa as the portfolio. 7. Check that the image is exported correctly to Picasa.

    Description

      This was performed on a "public" Qa site, but not qa.moodle.net.

      Steps 4,5 and Steps 6,7 worked,

      However Steps 1,2,3 testing box.net export for the forum post did not work

      Even though box.net was working for exporting the attachment, when i tried to export the post I got the error:

      "Sorry, but there are no available portfolios for you to export to"
      and link to http://docs.moodle.org/21/en/error/portfolio/noavailableplugins

      Attachments

        Issue Links

          Activity

            People

              rwijaya Rossiani Wijaya
              rwijaya Rossiani Wijaya
              Ankit Agarwal Ankit Agarwal
              Aparup Banerjee Aparup Banerjee
              Aparup Banerjee Aparup Banerjee
              Adrian Greeve, Ilya Tregubov, Kevin Percy, Mathew May, Mihail Geshoski, Shamim Rezaie, David Woloszyn, Huong Nguyen, Jake Dallimore, Meirza, Michael Hawkins, Raquel Ortega, Safat Shahin, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                5/Dec/11