Moodle
  1. Moodle
  2. MDL-30374

Portfolio export from Forum not working as expected

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Not a bug
    • Affects Version/s: 2.2
    • Fix Version/s: None
    • Component/s: Forum, Portfolio API
    • Labels:
    • Environment:
      qa.moodle.net
    • Testing Instructions:

      From QA test:
      1. Login as the student and make an assignment submission.
      2. Try exporting the assignment submission to Mahara.
      3. Check that the assignment submission is exported correctly to Mahara and appears as a file.
      4. Make a forum post with attachment.
      5. Try exporting the forum post to Mahara, selecting LEAP2A as export format.
      6. Check that the post is exported correctly to Mahara and appears as a journal or blog with attachment.
      7. Add an entry to the glossary.
      8. Try exporting the glossary entry to Mahara, selecting LEAP2A as export format.
      9. Check that the entry is exported correctly to Mahara and appears as a journal or blog.

      Show
      From QA test: 1. Login as the student and make an assignment submission. 2. Try exporting the assignment submission to Mahara. 3. Check that the assignment submission is exported correctly to Mahara and appears as a file. 4. Make a forum post with attachment. 5. Try exporting the forum post to Mahara, selecting LEAP2A as export format. 6. Check that the post is exported correctly to Mahara and appears as a journal or blog with attachment. 7. Add an entry to the glossary. 8. Try exporting the glossary entry to Mahara, selecting LEAP2A as export format. 9. Check that the entry is exported correctly to Mahara and appears as a journal or blog.
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      32983

      Description

      When exporting to a portfolio from a forum post, options are not being presented.

      From the QA test "UI did not offer choice of HTML and LEAP2A on 4-6 Forum post export".

        Issue Links

          Activity

          David Mudrak added a comment -

          This is not a bug. The QA test instructions are to be clarified. The portfolio export does not need to ask for the format if it is negotiated automatically.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: