Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-3044

Users required to change password get stuck

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE

      Description

      When I set up an account manually for a user and select the option to require the user to change the password at their next login then when the user has logged in he gets stuck on login/change_password.php. This page is constantly being reloaded.

        Gliffy Diagrams

          Activity

          Hide
          dougiamas Martin Dougiamas added a comment -

          From Gustav Delius (gwd2 at york.ac.uk) Wednesday, 27 April 2005, 04:29 AM:

          This is because Martin put a require_login() onto login/change_password.php which in turn redirects to login/change_password, leading to the infinite loop.

          Because it looks like Martin has put some thought into this already I will let him fix this.

          From Don Hinkelman (hinkel at sgu.ac.jp) Wednesday, 27 April 2005, 12:53 PM:

          I had same problem with 1.5alpha. Downloaded April 26.

          Infinite looping when a user logs in after admin manually enrolls that user and requires new password.

          From Martin Dougiamas (martin at moodle.com) Wednesday, 27 April 2005, 09:51 PM:

          Fixed in CVS.

          It was the result of a security fix that was made too secure.

          Show
          dougiamas Martin Dougiamas added a comment - From Gustav Delius (gwd2 at york.ac.uk) Wednesday, 27 April 2005, 04:29 AM: This is because Martin put a require_login() onto login/change_password.php which in turn redirects to login/change_password, leading to the infinite loop. Because it looks like Martin has put some thought into this already I will let him fix this. From Don Hinkelman (hinkel at sgu.ac.jp) Wednesday, 27 April 2005, 12:53 PM: I had same problem with 1.5alpha. Downloaded April 26. Infinite looping when a user logs in after admin manually enrolls that user and requires new password. From Martin Dougiamas (martin at moodle.com) Wednesday, 27 April 2005, 09:51 PM: Fixed in CVS. It was the result of a security fix that was made too secure.
          Hide
          mblake Michael Blake added a comment -

          assign to a valid user

          Show
          mblake Michael Blake added a comment - assign to a valid user

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: