Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30487

Unit test failures (20_STABLE, 2.0.6)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.6, 2.1.3, 2.2
    • Fix Version/s: 2.0.7, 2.1.4
    • Component/s: Unit tests
    • Labels:

      Description

      While rolling 2.0.6, executing unit tests I've got:

      123/128 test cases complete: 4294 passes, 1 fails and 0 exceptions.

      Fail: filter/mediaplugin/simpletest/testfiltermediaplugin.php / ▶ filter_mediaplugin_test / ▶ test_filter_mediaplugin_link
       
      Testing text: <a class="_blanktarget" href="http://moodle.org/testfile/test.flv?d=100x">test flv</a> at 
      [/Users/stronk7/git_moodle/integration/filter/mediaplugin/simpletest/testfiltermediaplugin.php line 110]

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              stronk7 Eloy Lafuente (stronk7) added a comment -

              An exactly the same test is also failing under 21_STABLE.

              salvetore Michael de Raadt added a comment -

              Still an issue with master prior to 2.2 release.

              abgreeve Adrian Greeve added a comment -

              Thanks to Rajesh for providing me with the fix for this. I couldn't find any other options for flv / f4v urls.

              skodak Petr Skoda added a comment -

              ahh, this is caused by the recent fix that ignores the extra params after ?, we just need to remove the failing test and probably add a new one.

              skodak Petr Skoda added a comment -

              the proposed regex change above is not correct, please fix only the unittests to reflect changes from MDL-30303, that is anything invalid after "?" xxx.flv?blah=blah is ignored.

              abgreeve Adrian Greeve added a comment -

              The regular expression has been reverted back to the original and the test string has now been modified.

              skodak Petr Skoda added a comment - - edited

              To integrators: please cherry pick to stable branches

              stronk7 Eloy Lafuente (stronk7) added a comment -

              (note: after reviewing this, it was considered that the best solution was to remove the test completely as far as had no sense anymore as invalid test)

              Integrated and backported to 21 and 20 stables.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              All tests passing under 20 and 21 STABLE. Still some to fix for master (but @ MDL-30347). So passed.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The master fixes corresponding to this issue have been sent upstream. Fixes for other branches (19, 20, 21 stable) will be sent in the very-next days.

              Thanks for the hard work! Closing, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    9/Jan/12