Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.1.4, 2.2.1
    • Component/s: Quiz, Themes
    • Labels:
    • Testing Instructions:
      1. Switch theme to Sky High.
      2. Select Report from Settings > Site-Administation
      3. Dock all blocks
      4. Try printing a report (eg: Config Changes as this will have lots of varied data) Print Pre-view works just as well.
      5. Check to see that the print-out is complete.
      Show
      Switch theme to Sky High. Select Report from Settings > Site-Administation Dock all blocks Try printing a report (eg: Config Changes as this will have lots of varied data) Print Pre-view works just as well. Check to see that the print-out is complete.
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Gliffy Diagrams

        Issue Links

          Activity

          lazydaisy Mary Evans added a comment -

          @Dietmar
          Just added you as a watcher in this issue.

          I tested the report last night and all seems well.
          I still think the footer needs looking at as it did not display correctly in report.

          Will check this later.

          Big strikes in the UK today so looking after youngest grand-daughter because schools are closed!

          Cheera
          Mary

          dxxw Dietmar Wagner added a comment -

          Thanks, Mary!
          I'm on board!

          Cheers
          Dietmar

          lazydaisy Mary Evans added a comment -

          Hi Dietmar,

          I've just spent the last hour or so looking at this problem and tidied up the footer as I don't like <center> it's not XHTML and looks bad. I also think the way the output for standard footer HTML was not in the correct place as this (I think) is what helps trigger the performance info, validation, purge all caches, etcetera...

          The next bit is to fix the head.

          Also, I am not happy that the print-preview, which I use when viewing the report prior to printing, still shows the blocks if you happen to leave them visible. On the other hand if you dock the blocks it shows the dock tabs, and yet in layout options, in config.php, it say "noblocks" = true. This leaves me wondering if noblocks = true = no and noblocks = false = yes a kind of reverse logic!

          I'll let you know how I get on.

          Cheers
          Mary

          lazydaisy Mary Evans added a comment -

          Well the plan is to get this fixed today...so starting now...but please don't time me

          samhemelryk Sam Hemelryk added a comment -

          Thanks Mary, this has been integrated to 21, 22, and master branches.

          samhemelryk Sam Hemelryk added a comment -

          Tested during integration and passed.

          lazydaisy Mary Evans added a comment -

          Thanks Sam!

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks!

          Now... disconnect, relax and enjoy the next days, yay!

          Closing...ciao

          rob13 Rob added a comment -

          Hi Mary,

          I am writing to offer feedback on your progress on this issue. I updated to the latest 2.1.3+ yesterday, and notice quiz results and config changes print correctly. What is odd about these pages is they do not display my custom logo in the browser.

          I still get truncated results on many other print jobs using Sky High. Activity logs to not print correctly, for example. I have attached a PDF of my own activity logs from my production site.

          I am sorry to bring this up again. I appreciate the attention you have paid to it so far.

          Rob

          rob13 Rob added a comment - - edited

          File showing truncated activity logs attached above.

          lazydaisy Mary Evans added a comment -

          Hi Rob,

          I'm glad you took the time to give us some FEEDBACK as this is what the tracker is all about.

          The reason you don't see the Logo is that the report page is using Base themes report layout. The idea was to minimise on graphics for printing purposes. Hence the minimalist view.

          I'll check the activity report out and get back to you.

          Thanks
          Mary

          dxxw Dietmar Wagner added a comment -

          Hi Mary,
          I have a good deal of work at the moment. I considered to move to subplanet Pluto as a day has at about 153 hours overthere.
          Ok. Only one thought: Could it be a good idea to customize the print layout via settings page (logo, navbar, custommenu, ...: display: none/block)!?

          @Rob: Can you direct me to the page shown in your pdf-file?

          Cheers
          Dietmar

          rob13 Rob added a comment -

          Hi Dietmar,

          The PDF I attached is my activity log. I logged into the site, clicked my name in the upper right, and clicked "Today's logs" in the navigation block under activity reports. Site activity reports truncate, but course activity reports do not (no custom logo). Also, I had a teacher report that when she tried to print a quiz to make an answer key, it was truncated.

          I appreciate your time and attention on this. Don't give up on Earth just yet. Pluto is very cold this time of year.

          Rob

          dxxw Dietmar Wagner added a comment -

          Thanks for your hints, Rob!

          I had a hasty glance and the problem seems to be again a missing body class (@Mary: of course .pagelayout-report. Perhaps we can find a similar solution as we did for other reports!)

          Rob, I think I should forget Pluto. I even do not know if they use Moodle out there

          Cheers
          Dietmar

          lazydaisy Mary Evans added a comment -

          Hi Dietmar,

          Pluto sounds a good place! LOL

          The problem is still with Sky High, and I think is the footer which is spoiling things, I need to fix these problems as well as find a solution to the Reports that don't use the report layout.

          If you recall the Activity logs were the one that I could not change in the way we wanted, adding the pagelayout-report, as these report seem to link to a settings page which I could not figure out at the time. So they use the general page instead.
          I think that is why it truncates, because that page is wrong!

          I'm planning on getting this done this done this week.

          I will take a look in the Morning.
          Cheers
          Mary

          dxxw Dietmar Wagner added a comment -

          Hi Mary,
          I went through all the reports in 2.2 and we have as far as I see only three kinds of pagelayouts:

          • pagelayout-report(backup, completion, configlog, courseoverview, log, loglive, outline, progress, questioninstances, security, stats for admins)
          • pagelayout-popup (loglive)
          • pagelayout-admin(participation and stats for users)

          In sky_high/config.php we have

          'admin' => array(
          'file' => 'general.php',
          'regions' => array('side-pre'),
          'defaultregion' => 'side-pre',
          ),

          Why not changing this to

          'admin' => array(
          'theme' => 'base', //as we have for report
          'file' => 'report.php',
          'regions' => array('side-pre'),
          'defaultregion' => 'side-pre',
          ),

          and add some .pagelayout-admin rules to report.css?!

          What do you think about that?

          Cheers
          Dietmar

          lazydaisy Mary Evans added a comment -

          Hi Dietmar,

          What a good idea! Why didn't I think of that? LOL
          It makes perfect sense. In fact looking at this from a general viewpoint, would be to have an Admin theme where all this could marry up.

          Perhaps this should go on the TODO list!

          I'll take a look at this now and see how it looks.

          Cheers
          Mary


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                9/Jan/12