Moodle
  1. Moodle
  2. MDL-30522

User profile fields: Hidden fields not visible to admins

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Administration
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      Create user profile field
      Who is the field visible to? : Not visible
      Save

      Login as admin.
      View any user profile
      Field info not visible to admin

        Gliffy Diagrams

          Activity

          Ray Lawrence created issue -
          Rajesh Taneja added a comment -

          Thanks for reporting this issue Ray,

          I don't think this is a bug, but a functionality.
          You have to put some value for custom profile field before you can view this as admin.

          1. Login as admin.
          2. Create user profile field (Myprofile) and set visibility to "Not visible"
          3. View any user profile
          4. Edit this user profile and enter some value for Myprofile field
          5. View profile again and Myprofile field should now be visible.
          Rajesh Taneja made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Not a bug [ 7 ]

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: