Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30524

Hidden items not grayed out using IE8 after upgrade to 2.1.3

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1.3
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      Suse 11.4, php 5.3, Mysql
    • Database:
      Any
    • Testing Instructions:

      Install Moodle 2.1.3. Log in with IE8. Create some resouces/activities. Hide one or more items. Notice link turns gray. Reload page, and link will be blue.

      Show
      Install Moodle 2.1.3. Log in with IE8. Create some resouces/activities. Hide one or more items. Notice link turns gray. Reload page, and link will be blue.
    • Workaround:

      Use a different browser, if possible.

      Show
      Use a different browser, if possible.
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      Moodle 2.1.3 is not displaying hidden resources, activities and courses with a gray link with Internet Explorer 8. The teacher must turn editing on to see what is hidden from students (eye closed). It is confusing for teachers.

      If the teacher turns editing on and hides an item, the link does turn gray, but it turns back to blue after a page reload. This happens regardless of theme. IE9 and FF work as expected.

      Discussion about this is:
      http://moodle.org/mod/forum/discuss.php?d=191313

        Gliffy Diagrams

          Issue Links

            Activity

            smithrn Ryan Smith added a comment -

            I can reproduce this problem on IE8. The bug also affects IE7.

            jtuttle Tuttle, James added a comment -

            This is also a bug when going from Moodle 2.0.4+ to 2.0.7+, and I can reproduce it on Internet Explorer 9 as well as 8 and 7.

            lazydaisy Mary Evans added a comment -

            This sounds like a theme issue. However...just to make sure. Are you sure you are using not viwing this in IE8 Compatibility Mode as this can trigger odd things happening. To check when in IE8 click on F12 (Function Key) you should see in the lower half of your browser window a panel appear where there is a menu where you can actually select the different views. The image I have uploaded is an IE9 version but even so it's similar in IE8.

            I am aware that IE doesn't like links coded as just a it like the full works a:link, a:visited,a:active,a:hover in that order.

            It could be with the changes going on in the themes that styles have got re-ordered somehow.

            Thanks for posting this in the theme's forum, else who knows how ling it would have sat here! LOL

            Cheers
            Mary.

            rob13 Rob added a comment -

            Thank you for assigning yourself to this issue Mary. My teachers have been complaining for the last month over it. In 2.1.3+ from last week, IE9 works fine.

            Rob

            lvazdela Luis Vázquez de Lara added a comment -

            This is also happening with Moodle 2.1.4+ when using IE 8 and 9

            bostelm Henning Bostelmann added a comment - - edited

            This is a regression bug caused by a change in theme/base/style/core.css in the context of MDL-26712.

            As an emergency measure, reverting the following change fixes the problem:

            https://github.com/phalacee/moodle/commit/1d559a1eb0848f53deb4c44f41388698dbcddab2

            (After doing this change, clear all caches in Moodle.)

            lazydaisy Mary Evans added a comment -

            This should be fixed soon.


              People

              • Votes:
                7 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: