Moodle
  1. Moodle
  2. MDL-30542

Backport webservice/upload.php 2.2 changes in 2.1 when possible

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1.3, 2.2, 2.3
    • Fix Version/s: 2.1.4, 2.2
    • Component/s: Web Services
    • Labels:
    • Rank:
      33256

      Description

      We missed few fixes in 2.1:

      2.2 commit history: MDL-27497, MDL-29036, MDL-29602, MDL-28646, MDL-28646, MDL-30459 (integrated), MDL-30459(integrated), MDL-30496 (integration review)
      2.1 commit history: MDL-27497, MDL-29036

        Issue Links

          Activity

          Hide
          Jérôme Mouneyrac added a comment -

          Apu I added you as peer reviewer (for after 2.2 release). You can give it to someone else if you don't have time. The only difference with 2.2 is that I didn't integrate MDL-29036 as it's not in 2.1.

          Show
          Jérôme Mouneyrac added a comment - Apu I added you as peer reviewer (for after 2.2 release). You can give it to someone else if you don't have time. The only difference with 2.2 is that I didn't integrate MDL-29036 as it's not in 2.1.
          Hide
          Rossiani Wijaya added a comment -

          Hi Jerome,

          Some minor issues that I spotted:

          1. In webservice/upload.php, typo on line 22 'aaera'.
          on line 126, there is double ';'.

          2. In lang/en/webservice.php, for 'servicenotavailable' string, the first letter need to uppercase and maybe it should be re-word to something like "Web service is not available (it is not exist or might be set to disable)".

          3. In webservice/lib.php, on line 83, should be 'cannot' and probably should be re-word to 'Refuse non-admin authentication in maintenance mode).
          on line 68, do you mean 'retrieve user info from the token'?

          4. It needs some test instructions.

          I will continue reviewing the patch tomorrow.

          Show
          Rossiani Wijaya added a comment - Hi Jerome, Some minor issues that I spotted: 1. In webservice/upload.php, typo on line 22 'aaera'. on line 126, there is double ';'. 2. In lang/en/webservice.php, for 'servicenotavailable' string, the first letter need to uppercase and maybe it should be re-word to something like "Web service is not available (it is not exist or might be set to disable)". 3. In webservice/lib.php, on line 83, should be 'cannot' and probably should be re-word to 'Refuse non-admin authentication in maintenance mode). on line 68, do you mean 'retrieve user info from the token'? 4. It needs some test instructions. I will continue reviewing the patch tomorrow.
          Hide
          Rossiani Wijaya added a comment -

          Hi Jerome,

          The rest of the code looks good.

          Show
          Rossiani Wijaya added a comment - Hi Jerome, The rest of the code looks good.
          Hide
          Jérôme Mouneyrac added a comment -

          Thanks Rosie, I'll make the changes and submit it

          Show
          Jérôme Mouneyrac added a comment - Thanks Rosie, I'll make the changes and submit it
          Hide
          Aparup Banerjee added a comment -

          Hi Jerome,
          I just had a quick glance (gtg play futsal with you): $string['servicenotavailable'] = 'Web service is not available (it is not existing or might be set to disable)'; --> disabled , not sure if thats in the other branches as well

          Show
          Aparup Banerjee added a comment - Hi Jerome, I just had a quick glance (gtg play futsal with you): $string ['servicenotavailable'] = 'Web service is not available (it is not existing or might be set to disable)'; --> disabled , not sure if thats in the other branches as well
          Hide
          Jérôme Mouneyrac added a comment - - edited

          Hi Apu,
          good catch, I'm going to add a quick fix for the 2.2 branch here if it's ok

          Show
          Jérôme Mouneyrac added a comment - - edited Hi Apu, good catch, I'm going to add a quick fix for the 2.2 branch here if it's ok
          Hide
          Aparup Banerjee added a comment -

          I've spoken to Jerome,
          we'll reopen this as there are few minor (ie:typos/strings) issues to look at (both back porting and the fixes already in 2.2).

          Show
          Aparup Banerjee added a comment - I've spoken to Jerome, we'll reopen this as there are few minor (ie:typos/strings) issues to look at (both back porting and the fixes already in 2.2).
          Hide
          Jérôme Mouneyrac added a comment -

          No worries I'll backport the fix of the backport.

          Show
          Jérôme Mouneyrac added a comment - No worries I'll backport the fix of the backport.
          Hide
          Jérôme Mouneyrac added a comment -

          I added a commit for the string fix to 2.2 and HEAD

          Show
          Jérôme Mouneyrac added a comment - I added a commit for the string fix to 2.2 and HEAD
          Hide
          Aparup Banerjee added a comment -

          Thanks this all has been integrated (patch into 2.1 and picked fixes into master/2.2)

          had some git madness (empty picks) there for a sec , i gotta upgrade my git version to get more verbosity.

          ciao!

          Show
          Aparup Banerjee added a comment - Thanks this all has been integrated (patch into 2.1 and picked fixes into master/2.2) had some git madness (empty picks) there for a sec , i gotta upgrade my git version to get more verbosity. ciao!
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Tested and passed...

          But when running the PHP-HTTP-filehandling against 21_STABLE I detected that the download option is missing in that branch, so upload worked ok but download did not.

          Up to you if that needs something extra or is ok for 21_STABLE (I guess it's ok, but just to be 100% sure).

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Tested and passed... But when running the PHP-HTTP-filehandling against 21_STABLE I detected that the download option is missing in that branch, so upload worked ok but download did not. Up to you if that needs something extra or is ok for 21_STABLE (I guess it's ok, but just to be 100% sure). Ciao
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Yes, you did it!

          Now your code is part of the best weeklies released ever, many thanks!

          Closing, ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Yes, you did it! Now your code is part of the best weeklies released ever, many thanks! Closing, ciao
          Hide
          Jérôme Mouneyrac added a comment -

          "Web service" download solution is not supported in 2.1. It's a new feature specially created for promoting 2.2

          Show
          Jérôme Mouneyrac added a comment - "Web service" download solution is not supported in 2.1. It's a new feature specially created for promoting 2.2

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: