Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30582

Navigation doesn't generate correctly for front page modules

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.6, 2.1.3, 2.2, 2.3
    • Fix Version/s: 2.0.7, 2.1.4, 2.2.1
    • Component/s: Navigation
    • Labels:

      Description

      There is a bug between the database module and the navigation.
      The navigation generates activities with URL's using the id param - however the database module doesn't register its URLs with id, it uses a d param.

      The fallover matching means that there is a good chance the wrong data module is marked active if the user is browsing a data module in a course with many data modules.

        Gliffy Diagrams

          Attachments

            Activity

            samhemelryk Sam Hemelryk added a comment -

            Putting this up for peer-review now

            andyjdavis Andrew Davis added a comment -

            Im not going to pretend to full understand the ramifications of what you're doing here but it looks good to me

            samhemelryk Sam Hemelryk added a comment -

            Thanks for that Andrew - putting this up for integration now.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks (and also because of the explanations).

            Ciao

            rajeshtaneja Rajesh Taneja added a comment -

            Works Great
            Thanks Sam, for fixing this issue.

            FYI:
            If logged in as guest and activity is expanded, then there is no way to collapse all of them.
            Steps to reproduce:

            1. Add 2 database activities on front page.
            2. Log in a guest
            3. click on first first db activity icon
            4. Again click on first db activity icon, this time it collapse and expand again.
            5. click on second db activity and the first one closes. (Not sure but this is seems to be a bug too.)
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Yes, you did it!

            Now your code is part of the best weeklies released ever, many thanks!

            Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Jan/12