Moodle
  1. Moodle
  2. MDL-30605

Decide Moodle 2.3 requirements and push them to environment.xml

    Details

    • Testing Instructions:
      Hide

      0) To test exclusively in stable branches (from 19 to 22)
      1) Go to admin -> server -> environment
      2) One "2.3 upwards" Moodle version should be available
      3) It shows ... (to define)

      Show
      0) To test exclusively in stable branches (from 19 to 22) 1) Go to admin -> server -> environment 2) One "2.3 upwards" Moodle version should be available 3) It shows ... (to define)
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w51_MDL-30605_m23_env23
    • Rank:
      33406

      Description

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      Ciao

        Issue Links

          Activity

          Hide
          Petr Škoda added a comment -

          ah, I missed this issue when it was created, I have already patched environment file in MDL-30610 and also fix one major problem related to upgrading of dev sites.

          Show
          Petr Škoda added a comment - ah, I missed this issue when it was created, I have already patched environment file in MDL-30610 and also fix one major problem related to upgrading of dev sites.
          Hide
          Petr Škoda added a comment -

          The requirements for 2.3 should not require any changes except that Moodle 2.2.x requirement.

          The master branch needs a patch that prevents upgrade 2.2dev -> 2.3, I did not find better way than the hack in second commit, sorry.

          To integrators: if this gets accepted please cherry pick from the 2.2 branch to 2.1,2.0 and 1.9 stable branches.

          Show
          Petr Škoda added a comment - The requirements for 2.3 should not require any changes except that Moodle 2.2.x requirement. The master branch needs a patch that prevents upgrade 2.2dev -> 2.3, I did not find better way than the hack in second commit, sorry. To integrators: if this gets accepted please cherry pick from the 2.2 branch to 2.1,2.0 and 1.9 stable branches.
          Hide
          Petr Škoda added a comment -

          This was discussed today during dev meeting - it looks like nobody protested to keeping all other requirements the same.

          Show
          Petr Škoda added a comment - This was discussed today during dev meeting - it looks like nobody protested to keeping all other requirements the same.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks!

          (backported to 19, 20 & 21)

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated, thanks! (backported to 19, 20 & 21)
          Hide
          Eloy Lafuente (stronk7) added a comment - - edited

          Passing tests as the "2.3 and upwards" version was checked on all branches (showing 2.2 as requirement). Also master shown the release properly (instead of the calculated version).

          PS: This leaded me to think that perhaps we should add also support for "beta" and "rc" (they are shorter than "dev", but...)

          Show
          Eloy Lafuente (stronk7) added a comment - - edited Passing tests as the "2.3 and upwards" version was checked on all branches (showing 2.2 as requirement). Also master shown the release properly (instead of the calculated version). PS: This leaded me to think that perhaps we should add also support for "beta" and "rc" (they are shorter than "dev", but...)
          Hide
          Dan Poltawski added a comment -

          Our of interest what is the need for preventing a dev version of 2.2? Can it not be done with version numbers? I'm intrigued.

          Show
          Dan Poltawski added a comment - Our of interest what is the need for preventing a dev version of 2.2? Can it not be done with version numbers? I'm intrigued.
          Hide
          Petr Škoda added a comment -

          The environment requirement does not use version numbers - it uses human readable release info such as "2.2", "2.1" (do not ask me why). The problem is that at present anything that matches /^2\.2.*/ is ok for upgrade which is incorrect, my hack tries to explicitly disqualify 2.2dev...

          Show
          Petr Škoda added a comment - The environment requirement does not use version numbers - it uses human readable release info such as "2.2", "2.1" (do not ask me why). The problem is that at present anything that matches /^2\.2.*/ is ok for upgrade which is incorrect, my hack tries to explicitly disqualify 2.2dev...
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks!

          Now... disconnect, relax and enjoy the next days, yay!

          Closing...ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks! Now... disconnect, relax and enjoy the next days, yay! Closing...ciao

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: