Moodle
  1. Moodle
  2. MDL-30610

drop all upgrade and migration scripts early in 2.3dev

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: General
    • Labels:
    • Testing Instructions:
      Hide

      1/ test upgrade from 2.2 (it may not work before the version bump)
      2/ test fresh install
      3/ test install is blocked from 2.1 or earlier
      4/ test 2.1 upgrade works from 1.9 and fails from 1.9dev
      5/ try restore from 1.9 backup with all supported modules

      Show
      1/ test upgrade from 2.2 (it may not work before the version bump) 2/ test fresh install 3/ test install is blocked from 2.1 or earlier 4/ test 2.1 upgrade works from 1.9 and fails from 1.9dev 5/ try restore from 1.9 backup with all supported modules
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w52_MDL-30610_m23_upgradepurge

      Description

      It was planned some time ago to require Moodle 2.2 when upgrading to 2.3.
      I have also discovered that the environment test accepts dev version for requirements which is not correct.

        Gliffy Diagrams

          Issue Links

            Activity

            Petr Skoda created issue -
            Petr Skoda made changes -
            Field Original Value New Value
            Assignee moodle.com [ moodle.com ] Petr Škoda (skodak) [ skodak ]
            Petr Skoda made changes -
            Link This issue has been marked as being related by MDL-30604 [ MDL-30604 ]
            Petr Skoda made changes -
            Pull Master Diff URL https://github.com/skodak/moodle/compare/master...w50_MDL-30610_m23_upgradepurge
            Pull Master Branch w50_MDL-30610_m23_upgradepurge
            Pull 2.0 Diff URL https://github.com/skodak/moodle/compare/MOODLE_20_STABLE...w50_MDL-30610_m20_env23
            Pull 2.0 Branch w50_MDL-30610_m20_env23
            Testing Instructions 1/ test upgrade from 2.2 (it may not work before the version bump)
            2/ test fresh install
            3/ test install is blocked from 2.1 or earlier
            4/ test 2.1 upgrade works from 1.9 and fails from 1.9dev
            Description It was planned some time ago to require Moodle 2.2 when upgrading to 2.3.
            It was planned some time ago to require Moodle 2.2 when upgrading to 2.3.
            I have also discovered that the environment test accepts dev version for requirements which is not correct.

            Pull 2.2 Diff URL https://github.com/skodak/moodle/compare/MOODLE_22_STABLE...w50_MDL-30610_m22_env23
            Pull 2.1 Branch w50_MDL-30610_m21_env23
            Pull 2.2 Branch w50_MDL-30610_m22_env23
            Pull 2.1 Diff URL https://github.com/skodak/moodle/compare/MOODLE_21_STABLE...w50_MDL-30610_m21_env23
            Pull from Repository git://github.com/skodak/moodle.git
            Petr Skoda made changes -
            Status Open [ 1 ] Waiting for integration review [ 10010 ]
            Fix Version/s 2.0.7 [ 11451 ]
            Fix Version/s 2.1.4 [ 11452 ]
            Fix Version/s 2.2.1 [ 11456 ]
            Fix Version/s 2.3 [ 10657 ]
            Petr Skoda made changes -
            Link This issue has been marked as being related by MDL-30605 [ MDL-30605 ]
            Michael de Raadt made changes -
            Labels triaged
            Petr Skoda made changes -
            Testing Instructions 1/ test upgrade from 2.2 (it may not work before the version bump)
            2/ test fresh install
            3/ test install is blocked from 2.1 or earlier
            4/ test 2.1 upgrade works from 1.9 and fails from 1.9dev
            1/ test upgrade from 2.2 (it may not work before the version bump)
            2/ test fresh install
            3/ test install is blocked from 2.1 or earlier
            4/ test 2.1 upgrade works from 1.9 and fails from 1.9dev
            5/ try restore from 1.9 backup with all supported modules
            Eloy Lafuente (stronk7) made changes -
            Link This issue has been marked as being related by MDL-30605 [ MDL-30605 ]
            Eloy Lafuente (stronk7) made changes -
            Link This issue has been marked as being related by MDL-30604 [ MDL-30604 ]
            Eloy Lafuente (stronk7) made changes -
            Link This issue is blocked by MDL-30604 [ MDL-30604 ]
            Eloy Lafuente (stronk7) made changes -
            Link This issue is blocked by MDL-30605 [ MDL-30605 ]
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Yay, nice Petr, thanks!

            TO INTEGRATORS: This cannot be integrated before:

            • The two blockers above are done: (MDL-30604 and) MDL-30605.
            • The very first weeks of "sync" integration (22_STABLE & master) are running.

            (so I'd say that this cool cleanup won't happen before Xmas)

            Show
            Eloy Lafuente (stronk7) added a comment - Yay, nice Petr, thanks! TO INTEGRATORS: This cannot be integrated before: The two blockers above are done: ( MDL-30604 and) MDL-30605 . The very first weeks of "sync" integration (22_STABLE & master) are running. (so I'd say that this cool cleanup won't happen before Xmas)
            Hide
            Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Show
            Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
            Hide
            Petr Skoda added a comment - - edited

            rebased, env requirement in separate issue

            Show
            Petr Skoda added a comment - - edited rebased, env requirement in separate issue
            Petr Skoda made changes -
            Eloy Lafuente (stronk7) made changes -
            Labels triaged integration_held triaged
            Hide
            Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Show
            Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
            Petr Skoda made changes -
            Fix Version/s 2.0.7 [ 11451 ]
            Fix Version/s 2.1.4 [ 11452 ]
            Fix Version/s 2.2.1 [ 11456 ]
            Hide
            Petr Skoda added a comment -

            rebased, ciao

            Show
            Petr Skoda added a comment - rebased, ciao
            Eloy Lafuente (stronk7) made changes -
            Currently in integration Yes [ 10041 ]
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Not sure about which criteria you've followed to, sometimes yes/no, delete/keep these lines:

            // Moodle v2.2.0 release upgrade line
            // Put any upgrade step following this
            

            Nor why you've introduced these in main script:

            ////////////////////////////////////////
            ///upgrade supported only from 2.2.x ///
            ////////////////////////////////////////
            

            But who cares, I don't. Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - Not sure about which criteria you've followed to, sometimes yes/no, delete/keep these lines: // Moodle v2.2.0 release upgrade line // Put any upgrade step following this Nor why you've introduced these in main script: //////////////////////////////////////// ///upgrade supported only from 2.2.x /// //////////////////////////////////////// But who cares, I don't. Ciao
            Eloy Lafuente (stronk7) made changes -
            Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
            Integrator stronk7
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            I've added one commit bumping to 2012020200.00. So diverging has started, yay!

            Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - Integrated, thanks! I've added one commit bumping to 2012020200.00. So diverging has started, yay! Ciao
            Eloy Lafuente (stronk7) made changes -
            Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Added one more commit adding one (unreachable) upgrade_main_savepoint() call (within 2011120500) to have all the upgrade blocks balanced and passing the automated CI checks.

            Show
            Eloy Lafuente (stronk7) added a comment - Added one more commit adding one (unreachable) upgrade_main_savepoint() call (within 2011120500) to have all the upgrade blocks balanced and passing the automated CI checks.
            Hide
            Petr Skoda added a comment -

            thanks! the upgrade line inconsistence was introduced over the time when I was fixing merge conflicts...

            Show
            Petr Skoda added a comment - thanks! the upgrade line inconsistence was introduced over the time when I was fixing merge conflicts...
            moodle.com made changes -
            Tester phalacee
            Eloy Lafuente (stronk7) made changes -
            Labels integration_held triaged triaged
            Jason Fowler made changes -
            Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
            Hide
            Jason Fowler added a comment - - edited

            Petr, please explain why I am testing upgrading from 1.9 to 2.1 for code that was only introduced/modified in 2.3 ...

            The dev/integration version of 1.9 still allows me to upgrade to 2.1 the test instructions says it shouldn't ...

            Show
            Jason Fowler added a comment - - edited Petr, please explain why I am testing upgrading from 1.9 to 2.1 for code that was only introduced/modified in 2.3 ... The dev/integration version of 1.9 still allows me to upgrade to 2.1 the test instructions says it shouldn't ...
            Hide
            Jason Fowler added a comment -

            I'll pass this, based on the fact that the code does as it is supposed to, even if the test instructions include additional things that don't directly relate to the issue here

            Show
            Jason Fowler added a comment - I'll pass this, based on the fact that the code does as it is supposed to, even if the test instructions include additional things that don't directly relate to the issue here
            Jason Fowler made changes -
            Status Testing in progress [ 10011 ] Tested [ 10006 ]
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Side note, point 4 of testing instructions is, if I'm not wrong, one (wrong) leftover step, because the "dev" problem was fixed and tested by MDL-30605. So well done, Jason.

            Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - Side note, point 4 of testing instructions is, if I'm not wrong, one (wrong) leftover step, because the "dev" problem was fixed and tested by MDL-30605 . So well done, Jason. Ciao
            Hide
            Eloy Lafuente (stronk7) added a comment -

            The git and cvs repositories are happy receiving your very first contribution to Moodle for 2012. Happy new year!

            Closing, ciao

            Show
            Eloy Lafuente (stronk7) added a comment - The git and cvs repositories are happy receiving your very first contribution to Moodle for 2012. Happy new year! Closing, ciao
            Eloy Lafuente (stronk7) made changes -
            Status Tested [ 10006 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            Currently in integration Yes [ 10041 ]
            Integration date 05/Jan/12
            Hide
            Tim Hunt added a comment -

            This caused a fatal regression. The code in mod/workshop/form/accumulative/db/upgradelib.php that was deleted is used by restore from Moodle 1.9 code.

            I will open a new issue.

            Show
            Tim Hunt added a comment - This caused a fatal regression. The code in mod/workshop/form/accumulative/db/upgradelib.php that was deleted is used by restore from Moodle 1.9 code. I will open a new issue.
            Dan Poltawski made changes -
            Link This issue caused a regression MDL-31124 [ MDL-31124 ]
            Eloy Lafuente (stronk7) made changes -
            Link This issue caused a regression MDL-31333 [ MDL-31333 ]
            Hide
            Ashley Holman added a comment -

            Hi, this seems a bit drastic to drop all of this upgrade code. This complicates the upgrade path for those who are not yet on 2.2. Dropping 1.9 is fair enough but why drop 2.1 which came out less than a year ago? Given that there are two major releases per year now, and institutions will generally only have an opportunity to upgrade once per year, why not at least include the last 2 major versions so that a once-yearly upgrade is not complicated with having to create multiple code bases for the upgrade?

            Show
            Ashley Holman added a comment - Hi, this seems a bit drastic to drop all of this upgrade code. This complicates the upgrade path for those who are not yet on 2.2. Dropping 1.9 is fair enough but why drop 2.1 which came out less than a year ago? Given that there are two major releases per year now, and institutions will generally only have an opportunity to upgrade once per year, why not at least include the last 2 major versions so that a once-yearly upgrade is not complicated with having to create multiple code bases for the upgrade?

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: