Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.3
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
    • Testing Instructions:

      1/ test tinymce in moodle
      2/ test file picker integration - both files and links
      3/ concentrate on Moodle specific plugins - dragmath, moodlemotions, moodlenolink, moodlemedia, spellchecker

      Show
      1/ test tinymce in moodle 2/ test file picker integration - both files and links 3/ concentrate on Moodle specific plugins - dragmath, moodlemotions, moodlenolink, moodlemedia, spellchecker
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w10_MDL-30636_m23_tinymce

      Description

      When TinyMCE 3.4.8 becomes available, we should upgrade to fix bugs which are beginning to become apparent.

        Gliffy Diagrams

          Issue Links

            Activity

            Michael de Raadt added a comment -

            Hi, Petr.

            I'm assigning this to you as you have completed the last few upgrades. Please reassign if you don't want to do this.

            It would be good if we could upgrade TinyMCE to coincide with 2.3 release so that potential regressions can get a solid thrashing out with the QA tests.

            Petr Skoda added a comment -

            the next planned release is 3.4.7.1 see https://github.com/tinymce/tinymce/blob/master/changelog.txt

            Petr Skoda added a comment -

            If there is any problem in tinymce we should report it upstream or even submit patches there, then we usually link their tracker to ours...

            Petr Skoda added a comment -

            Hello,

            the tinymce github repo indicates the next major release will be 3.5.0, I am going to close this because there is no indication of any 3.4.8 anytime soon. Thanks for the report anyway.

            Unfortunately the 3.4.7.1 seems to be delayed more and more, if it takes more then a month I am going to try importing dev version into master to get some testing.

            Ciao

            Dan Marsden added a comment -

            reopening as 3.4.8 was released 2nd Feb - can we please have this included in at least 2.3 ?

            we just had a client report this issue which is fixed in newer release:
            http://www.tinymce.com/develop/bugtracker_view.php?id=4816

            Petr Skoda added a comment -

            I guess it would not be wise to backport this to all stable branches, in case of any problems in 2.2.x please revert immediately.

            Ciao

            Petr Skoda added a comment -

            3.4.9!

            Petr Skoda added a comment -

            rebased and updated to import 3.4.9

            Eloy Lafuente (stronk7) added a comment -

            I've created MDL-31913 about to backport this to 22 and 21 stables once this has been used by devs in master and no obvious breakage happens.

            Ciao

            Eloy Lafuente (stronk7) added a comment -

            Integrated (master only), thanks!

            Rajesh Taneja added a comment -

            Works Great.
            Tested:

            1. file picker integration by adding image and video's
            2. Added emoticons
            3. Added image, Audio and video
            4. Used dragmath
            5. Used spell checker
            6. Edit HTML source
            7. Checked basic editing features like table, formatting etc.

            Thanks for updating TinyMCE, Petr.

            Eloy Lafuente (stronk7) added a comment -

            Your changes are now upstream and will be included in the next minor released scheduled for March 13th (next Monday!).

            icao_reverse('arreis olik rebemevon afla letoh ognat');
            

            Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: