Moodle
  1. Moodle
  2. MDL-30652

Scorm Reports Goes to a locked state when there are no users to report

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2.2
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:
      1. Add a scorm package to a course and submit a few attempts from various students accounts
      2. Goto Scorm>Reports>basic as admin/teacher
      3. Select 'all users' from the settings and save
      4. In top navigation bar (appears only when there are more than 20 users in total) select a firstname such that no user should be reported
      5. Make sure you still can see the preferences form and the First name/last name navigation bar
      6. Delete all attempts and change settings to "users with attempts" and save
      7. Make sure you still can see the preferences form
      8. Repeat all above steps with interaction report (Scorm>reports>interactions)
      Show
      Add a scorm package to a course and submit a few attempts from various students accounts Goto Scorm>Reports>basic as admin/teacher Select 'all users' from the settings and save In top navigation bar (appears only when there are more than 20 users in total) select a firstname such that no user should be reported Make sure you still can see the preferences form and the First name/last name navigation bar Delete all attempts and change settings to "users with attempts" and save Make sure you still can see the preferences form Repeat all above steps with interaction report (Scorm>reports>interactions)
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      MDL-30652-master

      Description

      Goto scorm>report>basic
      Select show all users and save
      From the surname table select a Letter such that no user has a surname starting with that letter
      This will show something like
      0 results (0 users)
      Nothing to report

      Which is correct but the problem is, you end up in a locked state, the top selection bar is now not present so there is no way to change the selections.

        Gliffy Diagrams

          Issue Links

            Activity

            Dan Marsden added a comment -

            Hi Ankit, when you do this one can you please take a look at the bug I just linked to see if it resolves that one too? - thanks!

            Ankit Agarwal added a comment -

            Hi Dan,
            Got time to review this?

            Re:linked issue
            It seems it was already fixed during my Gsoc improvements. I checked both interaction and basic reports, seems fixed to me.
            Thanks

            Rossiani Wijaya added a comment -

            Patch looks good.

            Thanks Ankit.

            Ankit Agarwal added a comment -

            Thanks Rosie for the review.
            up for integration
            Thanks

            Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Sam Hemelryk added a comment -

            Thanks Ankit, this has been integrated now

            Adrian Greeve added a comment -

            It took me awhile to figure out the problem from the test instructions, but I got there in the end.
            This works fine.
            Thanks Ankit.

            Eloy Lafuente (stronk7) added a comment -

            This virus has been spread upstream, everybody will be infected soon. Congrats, you did it!

            Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: