Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30687

LDAP enrollment plugin ignores sitewide default settings for course creation

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2.1
    • Component/s: Enrolments
    • Labels:
    • Testing Instructions:

      1/ configura and enable LDAP fot course creation - do not set template course
      2/ sync and verify defaults used in new courses
      3/ add more course to ldap and set template course
      4/ sync and verify template used in new courses

      Show
      1/ configura and enable LDAP fot course creation - do not set template course 2/ sync and verify defaults used in new courses 3/ add more course to ldap and set template course 4/ sync and verify template used in new courses
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w51_MDL-30687_m23_ldapnewcourse

      Description

      see MDL-29117 for more detailed description

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              samhemelryk Sam Hemelryk added a comment -

              Thanks Petr this has been integrated now

              nebgor Aparup Banerjee added a comment -

              Jason, heres the doc if it helps :
              http://docs.moodle.org/22/en/LDAP_enrolment

              mudrd8mz David Mudrák added a comment -

              Let's rock'n'test

              mudrd8mz David Mudrák added a comment -

              Thanks Petr for a nice opportunity to finally prepare a full OpenLDAP setup on my notebook. I can confirm the newly created courses take data from the default settings or the template course.

              phalacee Jason Fowler added a comment -

              Thanks for getting this sorted David

              nebgor Aparup Banerjee added a comment -

              David, a quick doc would help (would definitely help our soon to be Tester ,Tim!) especially since you used openldap.
              Jason had been trying OpenLDAP and couldn't get anywhere with it.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks!

              Now... disconnect, relax and enjoy the next days, yay!

              Closing...ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    9/Jan/12