Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.2.5, 2.3.2
    • Fix Version/s: 2.2.6, 2.3.3
    • Component/s: Administration
    • Environment:
      Ubuntu server 10.04.3, MySQL 5.1.41-3ubuntu12.10; Apache/2.2.14 (Ubuntu); PHP Version 5.3.2-1ubuntu4.10
      Browsers tested: Internet Explorer 8, Firefox 6, Opera 11
    • Testing Instructions:
      1. Log in as admin
      2. Navigate to Site admin > Language > Language customization
      3. Select a language if you have more than one
      4. Check out the strings if you have not already done so
      5. In the list labelled "Show strings of these components" scroll to "filter_censor.php"
      6. Click "Show strings" and make sure the whole table is visible.
      7. resize browser to 800x600 and refresh page.
      8. Make sure full table is visible.
        Note: test this on all supported browsers.
      Show
      Log in as admin Navigate to Site admin > Language > Language customization Select a language if you have more than one Check out the strings if you have not already done so In the list labelled "Show strings of these components" scroll to "filter_censor.php" Click "Show strings" and make sure the whole table is visible. resize browser to 800x600 and refresh page. Make sure full table is visible. Note: test this on all supported browsers.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull Master Branch:
      wip-mdl-30691
    • Rank:
      33514

      Description

      Language customization / Filter Strings / Show strings to filter_censor.php
      Could not see the text box with words. It is out of the page and could not add/edit words.

      Replication steps:

      1. Log in as admin
      2. Navigate to Site admin > Language > Language customization
      3. Select a language if you have more than one
      4. Check out the strings if you have not already done so
      5. In the list labelled "Show strings of these components" scroll to "filter_censor.php"
      6. Prepare yourself for some bad langauge
      7. Click "Show strings"

        Activity

        Michael de Raadt added a comment -

        The textbox is there and visible if you have a sufficiently wide resolution, probably 1800 pixels or more.

        The problem is that, for a long string with no spaces, the browser does not wrap the contents within the table cell div, so the second column is forcing the table to overflow and the overflowing table contents is being hidden.

        In saying that, the overflow of the table should not be hidden. Either the page needs to be able to scroll or the contents of the "Standard text" cell needs to be able to scroll within a maximum width.

        I had a quick look and the max-width but the div within this cell has the class "preformatted". I'm not sure why this is the case. I wasn't able to get the cell contents to behave, but perhaps someone with more CSS knowledge and time could track this down.

        Rajesh Taneja added a comment -

        Tested on all browsers and it works fine. Solution has been added to c2 cell only as we don't expect other cells to have such big words.

        Adrian Greeve added a comment -

        [Y] Syntax
        [Y] Output
        [Y] Whitespace
        [N/A] Language
        [N/A] Databases
        [Y] Testing
        [N/A] Security
        [N/A] Documentation
        [Y] Git
        [Y] Sanity check

        I tested this to check out the problem and this solution. This will solve the problem no matter what resolution you are running at now.
        No problems found.

        Thanks Raj.

        Dan Poltawski added a comment -

        Integrated, thanks Raj

        Andrew Davis added a comment -

        I've tested this in Chrome and Firefox. It sounds like others have already tested it as well. Passing.

        Aparup Banerjee added a comment -

        Your issue has dug up some gold.
        It works great i've been told.
        Go forth, be brave, be bold.

        yay! "All your thoughts are belong to everyone."

        Thanks and ciao!


          People

          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: