Moodle
  1. Moodle
  2. MDL-30721

'New theme saved' page doesn't include required javascript for page blocks

    Details

    • Workaround:
      Hide

      Possible fix/workaround:

      diff --git a/theme/index.php b/theme/index.php
      index 7424d2b..f910fff 100644
      --- a/theme/index.php
      +++ b/theme/index.php
      @@ -69,6 +69,7 @@ if ($reset and confirm_sesskey()) {
           echo format_text(get_string('choosereadme', 'theme_'.$theme->name), FORMAT_MOODLE);
           echo $output->box_end();
           echo $output->continue_button($CFG->wwwroot . '/theme/index.php');
      +    echo $PAGE->requires->get_end_code();
           echo $output->footer();
           exit;
       }
       

      Show
      Possible fix/workaround: diff --git a/theme/index.php b/theme/index.php index 7424d2b..f910fff 100644 --- a/theme/index.php +++ b/theme/index.php @@ -69,6 +69,7 @@ if ($reset and confirm_sesskey()) { echo format_text(get_string('choosereadme', 'theme_'.$theme->name), FORMAT_MOODLE); echo $output->box_end(); echo $output->continue_button($CFG->wwwroot . '/theme/index.php'); + echo $PAGE->requires->get_end_code(); echo $output->footer(); exit; }  
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      'New theme saved' page doesn't include required javascript for page blocks ...
      After selecting a new theme, the page is displayed without required javascript for page blocks, etc.
      E.g. /theme/index.php?device=default&choose=formal_white&sesskey=v2MzhGY4QG

      Appears problem in: /theme/index.php

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Michael de Raadt added a comment -

            Thanks for reporting this.

            I've put it on our backlog.

            In the meantime adding more information, such as screenshots, replication instructions, fix test instructions, a workaround or even a code solution, will help us and other users. If you are able to provide a patch, please add a patch label so we will spot it.

            Show
            Michael de Raadt added a comment - Thanks for reporting this. I've put it on our backlog. In the meantime adding more information, such as screenshots, replication instructions, fix test instructions, a workaround or even a code solution, will help us and other users. If you are able to provide a patch, please add a patch label so we will spot it.
            Hide
            Andrew Davis added a comment -

            Hello. I am closing this issue as it appears to have been fixed at some point.

            Show
            Andrew Davis added a comment - Hello. I am closing this issue as it appears to have been fixed at some point.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: