Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30765

Instructors unable to run Activity Reports

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.1.4, 2.2.1
    • Component/s: General
    • Labels:

      Description

      Having upgraded to Moodle version 2.2 (Build: 20111205) last week, our instructors now encounter the following error as soon as they click the Course -> Reports -> Activity Report link:

      Debug info: Argument 2 passed to has_capability() must be an instance of context, null given, called in /data/web/moodle/report/outline/index.php on line 45 and defined
      Stack trace:
      line 365 of /lib/setuplib.php: coding_exception thrown
      line 348 of /lib/accesslib.php: call to default_error_handler()
      line 45 of /report/outline/index.php: call to has_capability()

      This seems to affect all instructors and all courses.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              I think this issue is being caused by database corruptions. Previously these corruptions were not being noticed, but with recent changes they are coming to light.

              Have a look at the linked issue. I suspect it is related and will help you track down your problem.

              wstone@santarosa.edu Bill Stone added a comment -

              I created and ran rebuildcontextpaths.php for 2.0 per directions, but this did not resolve the issue. I continue to see exactly the same error message (see above) each time I try to access Course -> Reports -> Activity Report.

              Any further thoughts or developments?

              Thanks.

              skodak Petr Skoda added a comment -

              Thanks for the report!

              samhemelryk Sam Hemelryk added a comment -

              Thanks Petr - this has been integrated now.

              ankit_frenz Ankit Agarwal added a comment -

              working as expected.
              No error msgs were shown
              Thanks

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks!

              Now... disconnect, relax and enjoy the next days, yay!

              Closing...ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    9/Jan/12