Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30770

Undefined variable: buttons in .../admin/settings.php on line 107

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2, 2.3
    • Fix Version/s: 2.1.4, 2.2.1
    • Component/s: Administration
    • Labels:

      Description

      Undefined variable: buttons in .../admin/settings.php on line 107

        Gliffy Diagrams

          Attachments

            Activity

            salvetore Michael de Raadt added a comment -

            Hi, Brent.

            I can see why this error is occurring, but could you add more to this report? Please tell us how you came across this error message and what steps we might take to replicate the problem. That will help us develop testing instructions once the problem is resolved.

            salvetore Michael de Raadt added a comment -

            Hi, Sam.

            Assigning this to you as it looks like the change came from one of your edits a while back.

            The line...

            $PAGE->set_button($buttons);

            ...should probably be shifted up to be inside the if body above after line 100.

            samhemelryk Sam Hemelryk added a comment -

            Putting this up for integration as its a very easy obvious fix.

            Integrators please cherry-pick to 21, and 22.
            Commit hash: 6be4afb

            Cheers
            Sam

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks! (21, 22 and master)

            ankit_frenz Ankit Agarwal added a comment -

            working as expected!
            Thanks

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks!

            Now... disconnect, relax and enjoy the next days, yay!

            Closing...ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Jan/12