Moodle
  1. Moodle
  2. MDL-30777

Improve error message of protected cartridges

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.3
    • Fix Version/s: 2.2.1
    • Component/s: Backup: IMS-CC
    • Labels:

      Description

      The error message with protected cartridges is: "error/Protected cartridge content - Skipping import!"

      This should read "Protected cartridges not supported."

        Gliffy Diagrams

          Activity

          Hide
          Darko Miletic added a comment -

          done

          Show
          Darko Miletic added a comment - done
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Uhm... is that message available to the final user? If so it needs to be done via lang strings instead of harcoded ones. Reopening...

          Show
          Eloy Lafuente (stronk7) added a comment - Uhm... is that message available to the final user? If so it needs to be done via lang strings instead of harcoded ones. Reopening...
          Hide
          Darko Miletic added a comment -

          take 2

          Show
          Darko Miletic added a comment - take 2
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Looks, better, thanks! I'm going to apply this both to 22_STABLE and master, correct?

          Also, in the mean time... could you point to any protected package out there? Note that testers do not (have to) know a word about it to be able to test.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Looks, better, thanks! I'm going to apply this both to 22_STABLE and master, correct? Also, in the mean time... could you point to any protected package out there? Note that testers do not (have to) know a word about it to be able to test. Ciao
          Hide
          Darko Miletic added a comment -

          Protected Common Cartridge 1.0

          Show
          Darko Miletic added a comment - Protected Common Cartridge 1.0
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Thanks, Darko... integrating...

          Show
          Eloy Lafuente (stronk7) added a comment - Thanks, Darko... integrating...
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated and backported to 22_STABLE, thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated and backported to 22_STABLE, thanks!
          Hide
          Rajesh Taneja added a comment -

          Restore end with ""Protected cartridges not supported." error on settings stage.
          Thanks for improving moodle, Darko

          Show
          Rajesh Taneja added a comment - Restore end with ""Protected cartridges not supported." error on settings stage. Thanks for improving moodle, Darko
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks!

          Now... disconnect, relax and enjoy the next days, yay!

          Closing...ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Whoever decided one week was worth 14 days had really one bad idea. Anyway, the nightmare is over, so thanks for your, once again, amazing contributions. Many, many thanks! Now... disconnect, relax and enjoy the next days, yay! Closing...ciao

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: