Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30265 Common Cartridge Export (take2)
  3. MDL-30783

Problems when exporting multiple choice quizz with correct answer grade fraction other than 1

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.1, 2.3
    • Fix Version/s: 2.2.2
    • Component/s: Backup: IMS-CC
    • Labels:
    • Testing Instructions:

      1. Import attached common cartridge package to this issue
      2. Enable converters on backup by setting @ config.php: $CFG->enablebackupconverters = true;
      3. Try to backup imported course as common cartridge

      Before this patch the backup will just fail
      After applying the patch you should be able to backup imported common cartridge without any issues.

      Show
      1. Import attached common cartridge package to this issue 2. Enable converters on backup by setting @ config.php: $CFG->enablebackupconverters = true; 3. Try to backup imported course as common cartridge Before this patch the backup will just fail After applying the patch you should be able to backup imported common cartridge without any issues.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      Must improve correct answer detection

        Gliffy Diagrams

          Attachments

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment - - edited

            Plz, testing instructions, we cannot go ahead with integration if missing. I'm moving this back to "submitted for integration" (for next week).

            Also, I guess you want the cc-export issues backported to 22_STABLE, correct? Specifying it with sort of "to integrators: this should go to master and 22" will help others for sure.

            Thanks! Ciao

            darko.miletic Darko Miletic added a comment -

            Testing package

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            darko.miletic Darko Miletic added a comment -

            OK, I will try doing that and if it fails I'll make new branches and update the issue.

            darko.miletic Darko Miletic added a comment -

            This branch was updated OK, should not give you any more issues.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Sorry Darko,

            but I must insist about testing instructions. They just include the restore and backup steps (I've added one about to enable exports) but it's missing what must be tested and where.

            That "what and where" can go from "TEST: the process ends without error" to "TEST: After backing-up the course the, xxxx.zip package will contain one xxxxxx.xml file which zzzzz element will have value 1.0000000"

            Please, specify the expected results to test. TIA!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The integration of this issue has been delayed to next week because the integration period is over (Monday, Tuesday) and testing must happen on Wednesday.

            This change to a more rigid timeframe on each integration/testing cycle aims to produce a better and clear separation and organization of tasks for everybody.

            This is a bulk-automated message, so if you want to blame somebody/thing/where, don't do it here (use git instead) :-D :-P

            Apologizes for the inconvenient, this will be integrated next week. Thanks for your collaboration & ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Crap, did I forget to reopen this last week? We need better testing instructions, to know what's expected after the operations. Reopening!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks! (22 and master).

            stronk7 Eloy Lafuente (stronk7) added a comment -

            While reviewing this, I ended following the testing instructions. Confirmed, once the patch is applied the test course in exportable without error. So that should be enough to consider this passed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This virus has been spread upstream, everybody will be infected soon. Congrats, you did it!

            Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/Mar/12