Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30812

Latest backup files generate error/setting_invalid_ui_label upon restore

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 2.1.3, 2.2, 2.3.3, 2.4.6, 2.5.2
    • 2.4.7, 2.5.3
    • Backup
    • Linux CentOS
    • 20
    • BACKEND Sprint 6

    Description

      Administrators and staff are unable to restore recently created course backup files. Prior to the upgrade to 2.1.3 any backup file created can be restored into a new course even now. Since this upgrade the restore process goes through the steps, but upon pressing "restore" an error/setting_invalid_ui_label is generated and upon pressing continue the restored course is showing up as an invisible course in the process of being restored, but never completes. We did an upgrade to the latest Moodle version 2.2 but this did not alleviate the error. The problem appears to be with the creation of the backup file as any created since the upgrade to 2.1.3 is now generating the error/setting_invalid_ui_label and all backups created prior to 2.1.3 can still be restored successfully.

      Attachments

        Issue Links

          Activity

            People

              rajeshtaneja Rajesh Taneja
              jnorris2 Joe Norris
              Mark Nelson Mark Nelson
              Damyon Wiese Damyon Wiese
              Damyon Wiese Damyon Wiese
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
              Votes:
              6 Vote for this issue
              Watchers:
              18 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                11/Nov/13