Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: STABLE backlog
    • Component/s: Themes
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      33827

      Description

      In testing MDL-30780 (Rubrics criterion with many levels), it was discovered that various elements within the original setup of that page come in to play and can end up with a situation where some data is lost in the right-hand margin of the page. This is particularly so when adding more levels for the various criteria needed.

        Issue Links

          Activity

          Mary Evans added a comment - - edited

          @Michael

          This may work if you add it to the core.css

          .editing #page-content

          {float:none;overflow:hidden;width:auto;}

          .editing #page-content #region-main .region-content

          {overflow-x: auto;}

          PS: I'll test it later today

          Michael de Raadt added a comment -

          Hi, Mary.

          Did this follow on from something?

          Mary Evans added a comment - - edited

          Yes it's following on from the RUBRIC editing page and is proving to be a pain in the neck, I wish now I had not started this, as the problem is in the way that particular editing page is set up. It would have been better for MDL-30780 to have been set to use the report layout as this would give it more flexibility.

          As it is now you get a shift to the right of the whole editing page it you attempt to add horizontal scroll bars, so it's not behaving as one would expect, which leads me to think Marina has got the whole design of the page wrong. But since that part is nothing to do with themes I'll stay out of it.

          But since the end result is affecting how themes work in that area, and in some ways is related to other page layout problems, and as there are a few other layouts that I am planning on looking at, I'll leave it open for the moment, and keep working on it, but may close it eventually as wont fix.

          Thanks

          Mary

          Michael OBrien added a comment - - edited

          Hi Mary Should I remove the line from grade/grading/form/rubric/styles.css
          .gradingform_rubric .criteria

          {font-size: 80%;}

          that I added earlier form mdl-30780 ?

          and use the css you suggested above instead?

          any need to remove the changes I added to render.php?

          Mary Evans added a comment - - edited

          You can although it's not doing any harm, in fact it helps, but it's not a total fix.
          There is more wrong in the page than I first thought.

          You can try adding the css I added in my other comment here, however even this is not doing much.

          I tried this using base theme and left editing on and you run into a real nest of vipers!

          My conclusion is that the page type is wrong for this particular set up. It should look like, and work similar to, the grade book page which allows the page to expand as needed.

          You are just going to have to be patient as coming up to Christmas my time is very limited but I will keep looking at this and see if I can find a solution.

          Michael OBrien added a comment - - edited

          I fully appreciate all the help I am getting on this and adding the change to core.css does help editing the rubric. I remove the ".editing" prefix so it would apply to when the coure is not in editing mode that got me out of a hole till something more roburst can be organised.

          What the edits did for me
          It gave me 2 levels in firefox of scrollbars inside the main browser window which allows you to use them in conjuction to view and use all the set levels.
          1 scrollbar appears under the rubrics itself, the other is at the bottom of the section just below the save, save next buttoms

          IE seems to be happy with just 1 scroll bar under the rubrics

          Thanks once again to all for the help with this


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: