Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30840

HTML Editor incorrectly handles nested lists

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Copy the content in the uploaded file (html_wiki_sample.txt) into a html format wiki (you will need to click on the "html" icon in the HTML editor tool bar to enter in raw HTML.
      2. Notice how the html content in the HTML editor looks the way it is suppose to: http://dl.dropbox.com/u/74397/moodle_wiki/before.png
      3. Now save the wiki and display the content again.
      4. Expected results:
        1. Output should be how the content looked like in the HTML editor
      5. Actual results:
        1. # Notice how the content doesn't look the same anymore: http://dl.dropbox.com/u/74397/moodle_wiki/after.png
        2. Now if you edit the wiki page, the html editor is also messed up: http://dl.dropbox.com/u/74397/moodle_wiki/after_editor.png
      Show
      Copy the content in the uploaded file (html_wiki_sample.txt) into a html format wiki (you will need to click on the "html" icon in the HTML editor tool bar to enter in raw HTML. Notice how the html content in the HTML editor looks the way it is suppose to: http://dl.dropbox.com/u/74397/moodle_wiki/before.png Now save the wiki and display the content again. Expected results: Output should be how the content looked like in the HTML editor Actual results: # Notice how the content doesn't look the same anymore: http://dl.dropbox.com/u/74397/moodle_wiki/after.png Now if you edit the wiki page, the html editor is also messed up: http://dl.dropbox.com/u/74397/moodle_wiki/after_editor.png
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE

      Description

      I posted in the forum about my experiences with nested lists and the HTML editor here: http://moodle.org/mod/forum/discuss.php?d=192632

      Basically, nested lists in Moodle 2.1/2.2 become messed up after saving anything that uses the HTML editor (wiki/forum). Nested lists initially look good in the HTML editor when you first edit them. However, upon saving both display and re-editing shows garbled HTML output.

        Attachments

        1. after.txt
          0.4 kB
        2. before.txt
          0.4 kB
        3. html_wiki_sample.txt
          0.5 kB

          Issue Links

            Activity

              People

              • Votes:
                8 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: