Moodle
  1. Moodle
  2. MDL-30926

"Invalid context ID" when trying to associate a blog entry with a course

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2.1
    • Component/s: Blog
    • Labels:
    • Testing Instructions:
      Hide

      1.Go to a 2.2 Moodle and in a course add the "blog menu"
      2.Click "add an entry about this course"
      3.Add your entry and try to save it.
      4.It will give the error message as above.
      5.From the blog menu, click "view entries about this course"
      6.From this screen, add an entry about this course.
      7.Try to save it and again, the error message will appear
      8. logic as user with guest access to course only, make sure links to add course and module associated posts is not available

      Show
      1.Go to a 2.2 Moodle and in a course add the "blog menu" 2.Click "add an entry about this course" 3.Add your entry and try to save it. 4.It will give the error message as above. 5.From the blog menu, click "view entries about this course" 6.From this screen, add an entry about this course. 7.Try to save it and again, the error message will appear 8. logic as user with guest access to course only, make sure links to add course and module associated posts is not available
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w52_MDL-30926_m23_blogassoc
    • Rank:
      33934

      Description

      When ticking the box "Blog about course (name)" the entry will not save and instead a message comes up as in the attached screenshot [[invalidcontextid]] I have tested this on 2 of my own 2.2 Moodles and the demo and the QA Moodle. I have not tested it on earlier Moodles so I don't know if the problem exists there as well.

        Issue Links

          Activity

          Hide
          Mary Cooch added a comment -

          Just to comment (apart from the fact that I came here today to add this to the tracker and wondered who had got here before me - and realised it was ME) - I have tried in a Moodle 2.0 and have no issues with attaching blog entries to a course, so something must have happened later on.

          Show
          Mary Cooch added a comment - Just to comment (apart from the fact that I came here today to add this to the tracker and wondered who had got here before me - and realised it was ME) - I have tried in a Moodle 2.0 and have no issues with attaching blog entries to a course, so something must have happened later on.
          Hide
          Petr Škoda added a comment -

          to integrators: please cherry pick to 2.2.x

          Thanks a lot for the report!

          Show
          Petr Škoda added a comment - to integrators: please cherry pick to 2.2.x Thanks a lot for the report!
          Hide
          Sam Hemelryk added a comment -

          Thanks Petr - this has been integrated now

          Show
          Sam Hemelryk added a comment - Thanks Petr - this has been integrated now
          Hide
          Jason Fowler added a comment -

          Fix works nicely

          Show
          Jason Fowler added a comment - Fix works nicely
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The git and cvs repositories are happy receiving your very first contribution to Moodle for 2012. Happy new year!

          Closing, ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The git and cvs repositories are happy receiving your very first contribution to Moodle for 2012. Happy new year! Closing, ciao

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: