Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30947

Fatal error: Cannot declare self-referencing constant '' in D:\xampp\htdocs\moodle\lib\dml\mysqli_native_moodle_database.php on line 296

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
      None
    • Environment:
      moodle is running under xampp on a windows server 2003 system desktop computer
    • Database:
      MySQL
    • Testing Instructions:

      Just try to access moodle on the location given below

      Show
      Just try to access moodle on the location given below
    • Workaround:

      Completly blocking acces to moodle

      Show
      Completly blocking acces to moodle
    • Difficulty:
      Difficult
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      When I try to access moodle i receive this error message.

        Gliffy Diagrams

          Activity

          skodak Petr Skoda added a comment -

          Hello,

          this looks like a PHP bug - google reveals other ppl have similar problems in other projects. Nobody else reported this problem yet in Moodle.

          Next time please tell us the exact Moodle version when reporting any line numbers.

          Please comment here if you find out more about this problem or if the PHP upgrade helped, thanks.

          Petr

          tainic Pedro Pinto added a comment -

          Thanks for your comment.

          The exact Moodle version is 2.0.3+ (Build: 20110616).
          The same php stuff is supporting another mysql based platform and never crashed (until now... at least).
          I found other people reporting same problem but, unfortunately with no answers.

          Pedro.

          skodak Petr Skoda added a comment -

          on line 296 there is only

          $this->mysqli = new mysqli($dbhost, $dbuser, $dbpass, $dbname, $dbport, $dbsocket);

          There is nothing wrong with Moodle code, so either there is something incorrect specified in config.php or it is a but in PHP. I guess it is a PHP bug, please always make sure you are running the latest PHP 5.3.x or XAMPP.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: