Moodle
  1. Moodle
  2. MDL-31102

Invalid HTML when previewing questions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.1.5, 2.2.2
    • Component/s: Questions
    • Labels:
      None
    • Rank:
      37529

      Description

      I happened to run the HTML validator on the question preview window.

        Activity

        Hide
        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Show
        Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
        Hide
        Sam Hemelryk added a comment -

        Thanks Tim - this has been integrated now.

        Show
        Sam Hemelryk added a comment - Thanks Tim - this has been integrated now.
        Hide
        Jason Fowler added a comment -

        The HTML validation comes back invalid due to the autocomplete attribute now, but the rest of it is fine.

        Show
        Jason Fowler added a comment - The HTML validation comes back invalid due to the autocomplete attribute now, but the rest of it is fine.
        Hide
        Tim Hunt added a comment -

        Jason, if you do View source, you will see that the autocomplete attribute is not there.

        It is added to the HTML using javascript (precisely to avoid validation problems) and so the validator only sees it if you do "Validate local HTML" using firefox web developer toolbar, or similar.

        Show
        Tim Hunt added a comment - Jason, if you do View source, you will see that the autocomplete attribute is not there. It is added to the HTML using javascript (precisely to avoid validation problems) and so the validator only sees it if you do "Validate local HTML" using firefox web developer toolbar, or similar.
        Hide
        Jason Fowler added a comment -

        Tim, I figured as much, which is why I passed the test

        Show
        Jason Fowler added a comment - Tim, I figured as much, which is why I passed the test
        Hide
        Eloy Lafuente (stronk7) added a comment -

        This is now available in the git and cvs repositories.

        Consider the responsibility of your fingerprints engraved there for future generations!

        Thanks for the work, closing, ciao

        Show
        Eloy Lafuente (stronk7) added a comment - This is now available in the git and cvs repositories. Consider the responsibility of your fingerprints engraved there for future generations! Thanks for the work, closing, ciao

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: