Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31127

PHP Notice when switching role

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1, 2.3
    • Fix Version/s: 2.2.2
    • Component/s: Roles / Access
    • Labels:
    • Environment:
      Moodle 2.2.1 (Build: 20120109) PHP Version 5.3.6, MySQL 5.1.57

      Description

      I am the administrator of my moodle. I go into my course, click on "switch role to student", and I get a code error (see attachment). I have "debug" turned on, which is why I am seeing this problem.

      I don't think it causes any errors or problems, but I wanted to let you know.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Thanks for reporting that, Rick.

              I was able to replicate the problem also. It doesn't seem to matter what role I switch to. It appears to happen only once after I log in. Switching roles a second time does not produce the error. I also see the same error on the course page immediately after I switch, but only until the page reloads. If I log out and log in again I am able to reproduce the error.

              I was not able to reproduce the error in 2.1, so this must be a recent regression. Yep, I found the issue: MDL-29602.

              skodak Petr Skoda added a comment - - edited

              Hello,

              I am not able to reproduce this problem, I have reviewed the code that initialises this array and did not find any problems. Did you install any contrib plugins or modify the code?

              Thanks for the report.

              Petr

              skodak Petr Skoda added a comment -

              oops, I have managed to replicate it now...

              skodak Petr Skoda added a comment -

              Thanks for the report!

              rjerz Rick Jerz added a comment -

              Petr,

              Thanks for noticing this problem. I feel good that I reported it. Sometimes I wonder if I should report these (minor) problems. But then I know that you folks really do care about fixing these issues. I am not trying to be bothersome. I really like Moodle and I like the support for it!

              skodak Petr Skoda added a comment -

              Rick, it is great when you report issues like this especially in the latest stable branch soon after release. Thanks again and keep reporting. Ciao

              skodak Petr Skoda added a comment -

              ah, I just discovered your other open reported issue, I might find some time later today to fix at least some easy ones, reciao

              rjerz Rick Jerz added a comment -

              I just added one more. See MDL-31127.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (22 and master), thanks!

              phalacee Jason Fowler added a comment -

              The notice is gone now. Nice work

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This is now available in the git and cvs repositories.

              Consider the responsibility of your fingerprints engraved there for future generations!

              Thanks for the work, closing, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/Mar/12