Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31143

If a question's average grade is 0, the quiz report displays an error.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.4, 2.2.1, 2.3
    • Fix Version/s: 2.1.5, 2.2.2
    • Component/s: Quiz
    • Labels:
      None
    • Testing Instructions:

      1. Create a quiz with an essay question.

      2. Make an attempt as a student.

      3. As a teacher/admin, go to the quiz overview report, and make sure the average question grade is shown as '-'. and that there are no PHP errors, even with Developer debug.

      Show
      1. Create a quiz with an essay question. 2. Make an attempt as a student. 3. As a teacher/admin, go to the quiz overview report, and make sure the average question grade is shown as '-'. and that there are no PHP errors, even with Developer debug.
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      This is a minor regression caused by MDL-30704

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              nebgor Aparup Banerjee added a comment -

              looks good to me, integrated and up for testing.

              gerry Gerard Caulfield added a comment -

              /mod/quiz/report.php?id=X&mode=overview

              I observed the pre patch errors and the fixes on 2.1 2.2 and master.

              Test passed

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This is now available in the git and cvs repositories.

              Consider the responsibility of your fingerprints engraved there for future generations!

              Thanks for the work, closing, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/Mar/12