Moodle
  1. Moodle
  2. MDL-31185

/mod/forum/lib.php in forum_get_posts_by_user() missing global $CFG

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.4, 2.2
    • Fix Version/s: 2.1.5, 2.2.2
    • Component/s: Forum
    • Labels:
    • Rank:
      37626

      Description

      This affects:
      1/ error message link when users do not share at least one course
      2/ unsupported forum_enabletimedposts feature

        Activity

        Hide
        Eloy Lafuente (stronk7) added a comment -

        Integrated (21, 22 & master), thanks!

        Show
        Eloy Lafuente (stronk7) added a comment - Integrated (21, 22 & master), thanks!
        Hide
        Eloy Lafuente (stronk7) added a comment -

        Although obvious, I've simulated the "groupnotamember" error and now it links properly to the course page without any notice.

        So passing, ciao

        Show
        Eloy Lafuente (stronk7) added a comment - Although obvious, I've simulated the "groupnotamember" error and now it links properly to the course page without any notice. So passing, ciao
        Hide
        Eloy Lafuente (stronk7) added a comment -

        Your nice code represents only 1/46 of the issues that have been sent upstream this week, so thanks, but not many.

        Nah, joking, many thanks! Closing this a fixed, ciao

        Show
        Eloy Lafuente (stronk7) added a comment - Your nice code represents only 1/46 of the issues that have been sent upstream this week, so thanks, but not many. Nah, joking, many thanks! Closing this a fixed, ciao

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: