Moodle
  1. Moodle
  2. MDL-31213

New password form field is not valid after 1.9.16 update

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.9.16, 2.0.7, 2.1.4, 2.2.1, 2.3
    • Fix Version/s: 1.9.17, 2.0.8, 2.1.5, 2.2.2
    • Labels:
    • Environment:
      CentOS 5.7 i386, MySQL 5.5.20 and PHP 5.3.9 (Remi repo), Lighttpd 1.4.26 with PHP-FPM
    • Database:
      MySQL
    • Testing Instructions:

      For developers:
      1/ go to page for adding new users
      2/ verify the html for password element
      3/ go to advancededitform code and change attributes to array('size'=>20) and verify again
      4/ remove the size attribute completely and verify again

      Show
      For developers: 1/ go to page for adding new users 2/ verify the html for password element 3/ go to advancededitform code and change attributes to array('size'=>20) and verify again 4/ remove the size attribute completely and verify again
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w03_MDL-31213_m23_attributesmess
    • Rank:
      37663

      Description

      After upgrading to 1.9.16 it is imposible to create a new account using /user/editadvanced.php?id=-1
      It always consider the password invalid

      On 1.9.15 it works and inside the HTML we can find

      <div class="felement fpassword"><input size="20" name="newpassword" type="password" onblur="validate_user_editadvanced_form_newpassword(this)" onchange="validate_user_editadvanced_form_newpassword(this)" id="id_newpassword" /><script type="text/javascript">

      On 1.9.16 it does not work and inside the HTML we can find

      <div class="felement fpassword"><input size="20"><script type="text/javascript">

      As you can see the "newpassword" form field is cropped.

        Activity

        Petr Škoda added a comment - - edited

        found it - bloody quickforms accept element attributes both as string and array!

        Petr Škoda added a comment -

        Sorry for the regression, this should be fixed in the next weekly build. Thanks a lot for the report.

        Generazion Consulting S.L. added a comment -

        Hi Petr,

        Thank you for the quick answer. We think that this problem is also present in 2.x branch.

        Regards

        Gustavo

        Eloy Lafuente (stronk7) added a comment -

        Yup, the issue is present in all branches. Petr has submitted fix for all them. They are being integrated right now, will be available in 48h from now.

        Thanks for reporting! Ciao

        Eloy Lafuente (stronk7) added a comment -

        Integrated (all branches from 19 to master), thanks!

        Michael de Raadt added a comment -

        Test result: Success

        I re-tested the previous issue that was related to the regression to ensure it is still working.

        I tested user creation, without, with and without the input size attribute in 1.9.

        I tested this as working in 2.1, 2.2 and integration master.

        Eloy Lafuente (stronk7) added a comment -

        This is now available in the git and cvs repositories.

        Consider the responsibility of your fingerprints engraved there for future generations!

        Thanks for the work, closing, ciao


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: