Moodle
  1. Moodle
  2. MDL-31240

Fix test_format_string() to test any $CFG->formatstringstriptags status

    Details

    • Testing Instructions:
      Hide
      • In admin interface set $CFG->formatstringstriptags = enabled
      • Run lib/simpletest/testweblib.php unittests.
      • TEST: No failures happen related for test_format_string()
      • In admin interface set $CFG->formatstringstriptags = disabled
      • Run lib/simpletest/testweblib.php unittests.
      • TEST: No failures happen related for test_format_string()
      • Note, under windows, it's possible to get some other failure when running lib/simpletest/testweblib.php, ignore it, we'll catch all them once the VMs are available. Just check none of them are related to test_format_string()
      Show
      In admin interface set $CFG->formatstringstriptags = enabled Run lib/simpletest/testweblib.php unittests. TEST: No failures happen related for test_format_string() In admin interface set $CFG->formatstringstriptags = disabled Run lib/simpletest/testweblib.php unittests. TEST: No failures happen related for test_format_string() Note, under windows, it's possible to get some other failure when running lib/simpletest/testweblib.php, ignore it, we'll catch all them once the VMs are available. Just check none of them are related to test_format_string()
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Rank:
      37701

      Description

      Running unittests for MDL-29091 revealed that the tests present @ test_format_string() are dependent of the status of the $CFG->formatstringstriptags setting, and they only pass if the setting is enabled (default status).

      This issue is about to fix that testing unit to support and test both modes, bringing independence from the $CFG var.

      That is.

        Issue Links

          Activity

          Hide
          Eloy Lafuente (stronk7) added a comment -

          This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

          For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

          Show
          Eloy Lafuente (stronk7) added a comment - This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue. For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment
          Hide
          vignesh p added a comment - - edited

          Hi, I could not find the file lib/simpletest/testweblib.php in the repo. Was this removed? Is this still a bug?

          -Vignesh

          Show
          vignesh p added a comment - - edited Hi, I could not find the file lib/simpletest/testweblib.php in the repo. Was this removed? Is this still a bug? -Vignesh

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: