Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31246

In a URL resource the 'Display' setting is Auto no matter what you select.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.3
    • Fix Version/s: None
    • Component/s: Resource
    • Labels:
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      As above; you can select whatever you like for this option but you get Auto.

      There's probably easier ways but I detected this by putting a trap in the url_get_final_display_type() function in locallib (mod/url/locallib.php). When displaying the $url object the 'display' field is always zero regardless of the selection. I tried this with a variety of URLs (just in case). Some with extensions, some not. Same result.

        Gliffy Diagrams

          Attachments

            Activity

            howardsmiller Howard Miller created issue -
            howardsmiller Howard Miller made changes -
            Field Original Value New Value
            Priority Minor [ 4 ] Major [ 3 ]
            Labels partner
            salvetore Michael de Raadt made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Cannot Reproduce [ 5 ]

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: