Moodle
  1. Moodle
  2. MDL-31353

Gradebook not saving with JavaScript error this.report.Y.io.queue not defined

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.2.1
    • Fix Version/s: 2.2.2
    • Component/s: Gradebook
    • Labels:
    • Database:
      Any
    • Testing Instructions:
      1. If you don't have one already then create a course, enrol some students, add some assignments.
      2. Go to the grader report for the course.
      3. Click on a table cell for one of the student's assignments. One or two text boxes should appear. If they dont check that the site setting grade_report_enableajax is checked.
      4. Enter the grade and hit Enter to save it.
      5. Refresh the page.

      Expected: the grade you entered should still be there.

      Show
      If you don't have one already then create a course, enrol some students, add some assignments. Go to the grader report for the course. Click on a table cell for one of the student's assignments. One or two text boxes should appear. If they dont check that the site setting grade_report_enableajax is checked. Enter the grade and hit Enter to save it. Refresh the page. Expected: the grade you entered should still be there.
    • Workaround:

      Use another way of entering grades that does not use AJAX. For example, click "Turn editing on" and enter grades, then click "Update"

      Show
      Use another way of entering grades that does not use AJAX. For example, click "Turn editing on" and enter grades, then click "Update"
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      MDL-31353_grader_io
    • Rank:
      37870

      Description

      Attempts to enter grades in the gradebook do not persist and a JavaScript error of this.report.Y.io.queue not defined is generated.

      I've included a patch that resolves the issue for us.

      The issue is that YUI's io-queue is not being loaded by the grader module, only io-base is being loaded.

      1. diff.patch
        0.8 kB
        David Penner

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for spotting that and providing a solution.

          Michael de Raadt added a comment -

          Bumping this issue as it has just been duplicated and seems quite serious.

          Andrew Davis added a comment -

          Adding a git branch and added a few little details to the testing instructions.

          This seems to fix the problem. We have previously done some fairly significant rewriting when we encountered a very similar error elsewhere. I'm wondering whether there was a reason for that that I can't recall now or if my memory is just playing tricks on me. I'll get this peer review by Sam Hemelryk as he is our resident JS guru.

          Sam Hemelryk added a comment -

          Hi Andrew, changes look spot on.
          One thing to check is that this works in the older stable branches which will be running older versions of YUI. Unfortunately they don't have API's for old versions that I could find so testing will be the best way.

          Cheers
          Sam

          Andrew Davis added a comment -

          The same fix works in 2.2 stable. 2.1 works fine without any alterations so this problem was introduced in 2.2

          Submitting for integration.

          Sam Hemelryk added a comment -

          Thanks Andrew, this has been integrated now

          Rajesh Taneja added a comment -

          Thanks for fixing this Andrew
          Works Great.

          Eloy Lafuente (stronk7) added a comment -

          Your changes are now upstream and will be included in the next minor released scheduled for March 13th (next Monday!).

          icao_reverse('arreis olik rebemevon afla letoh ognat');
          

          Closing, ciao


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: