Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31470

Completion report - filtering users breaks pagination

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.6
    • Fix Version/s: None
    • Component/s: Activity completion
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Seen in latest 2.0 not checked in 2.1/2.2.

      • Get hold of a course with lots of users and completion (need enough for filtered users to still be paginated, mine had 3k users)
      • Show the completion report
      • Filter the users (i.e. click a first name and last name letter)
      • Note: the remaining users still need to cover more than one page
      • click one of the page numbers

      The filtering is lost and you are back to the original screen

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              quen Sam Marshall added a comment -

              I'll investigate this if somebody verifies it still occurs on latest version (2.2 or master). Have a feeling it may have been fixed, but could be wrong (if so, long time ago).

              howardsmiller Howard Miller added a comment -

              I'll move the course into 2.2 later on and try it. Thanks.

              quen Sam Marshall added a comment -

              Thanks Howard!

              One note, if the problem still occurs, could you also confirm whether it is 'Activity completion' or 'Course completion' report that doesn't work - or of course it may well be both of them. (If the former, I need to fix it; if the latter, somebody else does.)

              salvetore Michael de Raadt added a comment -

              Hi, Howard.

              Is this still a problem?

              quen Sam Marshall added a comment -

              This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

              For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

              salvetore Michael de Raadt added a comment - - edited

              Hi, Howard.

              It would be good to know if this is still a problem?

              salvetore Michael de Raadt added a comment -

              I assume this is still an issue.

              howardsmiller Howard Miller added a comment -

              If nobody has fixed it then it will be. It's decidedly non-trivial to test / reproduce (because of the number of users needed)

              poltawski Dan Poltawski added a comment -

              I've tried to reproduce this and it works now - I think it was fixed by MDL-28945


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: