Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31481

Loss of initialsubscriptions capability prevents you from having a role which doesn't receive notifications by default

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.2.1
    • Fix Version/s: STABLE backlog
    • Component/s: Forum
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      We have several sets of users who are enrolled on courses in various roles but are not expected to participate actively. These are typically users such as:

      • Administrative Staff who typically require access to courses for various admin tasks
      • eLearning assistants who are often enrolled on courses whilst they assist tutors with various aspects of course creation

      With these roles and their expected usage, we've been asked to disable all notifications so that the users aren't unduly spammed and as such we've prevented capabilities such as:

      • mod/quiz:emailconfirmsubmission
      • mod/quiz:emailnotifysubmission
      • mod/feedback:receivemail

      We used to use the mod/forum:initialsubscriptions capability to ensure that these users aren't initially enrolled in forums on the course, but this capabiity was removed in MDL-30151 as part of some simplifications

      I'd like to suggest that something is added back which allows roles of this nature to not receive lots of notifications by default.

      It's quite conceivable for users who are in these roles to be students in other courses - this is certainly the case for the eLearning assistants, and we're also looking at the possibility of running courses for training various in-house tasks (e.g. use of MIS, finance, admissions, etc systems). As a result, asking users to set their initial subscription mode in their profile probably won't cut the mustard.

        Gliffy Diagrams

          Issue Links

            Activity

            salvetore Michael de Raadt added a comment -

            Thanks for reporting that, Andrew.

            Hmm. A fix for a regression causing a regression. Not good.

            rex Rex Lorenzo added a comment -

            Maybe instead of having "mod/forum:initialsubscriptions" capability it can just be called "mod/forum:receivemail"? Or is that hitting the hammer on the head too much, because it would disable all email notifications from the forum.

            But if that is okay, I can submit a patch to implement that feature, since it seems simple enough.

            rex Rex Lorenzo added a comment -

            I just submitted a patch to add the capability "mod/forum:receivemail" (MDL-33166).

            poltawski Dan Poltawski added a comment -

            Closing duplicate of MDL-33166


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: