Moodle
  1. Moodle
  2. MDL-31526

CLONE - Importing Section Headers and Section Header Description Text Not working in 2.0

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.2, 2.2
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
      None
    • Environment:
      Linux
    • Database:
      Microsoft SQL
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE
    • Rank:
      38076

      Description

      Teacher users are unable to import custom Section headers and accompanying section header descriptions from one course to the next. Nothing happens on the import. This is disastrous for our Course Designers and Instructional Designers!

      The workaround they are using is to make Labels as a substitute for the Section headers - which introduces a whole other area of complications....we need this fixed.

      This ticket was previously closed because it was stated that it replicated MDL-31525. The terminology in MDL-31525 is a little strange. This is what is happening in versions 2.90, 2.1, and 2.2. This is a terribly bad bug and should be fixed. Please do not close without addressing.

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Hi, Alfred.

          Thanks for persisting with this.

          It looks like your reports have been closed without too much information in response. My apologies for that.

          I believe you are experiencing the expected behaviour. In the case of an import or a restore that is merged into an existing course, section headers and descriptions are not being added because this could potentially overwrite existing information. This is a known behaviour based on a specific decision, so technically it is not a bug.

          However, that doesn't mean nothing can be done. I suggest we turn this into an improvement request that allows the admin/teacher to control whether section headers and descriptions overwrite those in a target course.

          Rex Lorenzo added a comment - - edited

          Running into the same issues in which our users coming from M19 to our new M2 system and importing their sites are not getting the section names/descriptions carried over.

          Can this be turned into an improvement request then?

          Also, if this isn't a bug because "section headers and descriptions are not being added because this could potentially overwrite existing information" then why don't section headers and descriptions still aren't being carried over when you do either:

          • Restore > Delete the contents of this course and then restore
          • Restore as a new course

          Still sounds like a bug to me.... well. At least for M19 backups.

          Michael de Raadt added a comment -

          This particular bug was resolved by MDL-27764. The problem was reported so many times, it's likely not all linked issues were closed.

          As for Moodle 1.9 backups, this would need to be reported as a separate issue, although I'm not sure if it will get attention at this stage.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: