Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31529

wrong param passed to css_store_css in theme/styles.php

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Log in as admin
      2. Purge cache (Site administration -> Development -> Purge all caches )
      3. Add a blog (My profile -> Blogs -> Add a new entry)
      4. Check error log and make sure no error is thrown.
      5. Editor should be visible.
      Show
      Log in as admin Purge cache (Site administration -> Development -> Purge all caches ) Add a blog (My profile -> Blogs -> Add a new entry) Check error log and make sure no error is thrown. Editor should be visible.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      wip-mdl-31529

      Description

      While adding CSS optimizer (MDL-29941), it third param was typed wrongly.
      Line -86 in theme/styles.php should be changed to $cssfiles.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              rwijaya Rossiani Wijaya added a comment -

              Hi Raj,

              This looks good.

              However, I checked on 2.2 and the issue is not exist there. Its only occur on 2.3. You might want to change the affected versions for this issue.

              Rosie

              rajeshtaneja Rajesh Taneja added a comment -

              CSS optimizer was added in master. But I was not sure of affected version, as it was discussed in Scrum, that affect version is released version. Anyways updated.

              Thanks for the feedback Rossie

              samhemelryk Sam Hemelryk added a comment -

              Thanks Raj, spot on and has been integrated now

              blepoxp Glenn Ansley added a comment -

              Confirmed presence of error in current master. Also confirmed solution prevents error from occurring in integrations log file. Looks good!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              It is late here and I'm very tired but I didn't want to go to sleep before expressing my admiration for your amazing collaboration. Thanks!

              Closing as fixed, heading to zzzZZZzzz, niao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12