Moodle
  1. Moodle
  2. MDL-31533

Please tell us more about yourself

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9.11
    • Fix Version/s: None
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      38086

      Description

      I am having a recurring problem with our moodle site. From time to time when a user tries to log in they get redirected to a page: "Please tell us more about yourself". There are various fields including name, city, town, email etc...

      If the user then updates required fields a message shows up : "This email address is already registered"... which causes the user to enter a different email address in order to leave this page. This then creates a new profile for the user which causes all sorts of problems as the new profiles are not enrolled in the relevant courses.

      Is there any way that I can stop this page (Please tell us more about yourself) showing up when users log on? Any advice would be much appreciated.

      I noted the previous blog about this issue but it did not fix my problem and the page kept showing up.

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for reporting that.

          Usually this page appears when there is required information missing from the user's profile. Populating the user's required fields should help avoid this.

          It would be good to know what form of authentication you are using. Is it manual, or are you using LDAP or something else?

          Michael de Raadt added a comment -

          You might want to have a look at the linked issue to see if the ideas there help you resolve this problem.

          Please let us know how you go.

          Simon Purdue added a comment -

          We only have a few participants on our moodle site so I just create new accounts manually for each new user needs access to our moodle site. I fill in the required fields when I create each account. E.g username, password, firstname, surname, email address, city/town, country. I block other users from seeing each other email address as this is our company policy.

          I then enrol each student in their relevant course and put a security key on each course so that students can not enrol for courses that are not relevant to them. when the 'tell us more about yourself' page appears, it forces the user to enter a different email address and thus creates a new account. Which means the user is no longer able to access their relevant courses.

          Is there another stage in setting up the accounts process that I am missing? do I need to confirm users or authenticate them?

          Michael de Raadt added a comment -

          Hi, Simon.

          If you have manually created the accounts and filled in the required fields, then it should not be requesting additional information. There are no further steps needed to complete someone's account if all that information is there.

          I tried a couple of things you mentioned, but I did not experience the problem you mentioned, however you did say it was intermittent.

          How are you preventing students from seeing each other's emails? Is this done in each user's profile or on the User policies page?
          How do your settings on the User policies page differ from the defaults?
          You should not need to add a "security key" (enrolment key?) to courses if you are enrolling students manually. Just turn off the setting in each course to allow Guest access.

          Simon Purdue added a comment -

          the problem is intermittent. It doesn happen to all users. I prevent the other students from seeing the emails by selecting the 'hide my email address from everyone' function on the edit profile page/account creation page which I have attached.

          I have attached my user policy page. Do you notice anything strange?

          I add an enrollment key so that users can not join courses that they shouldnt be joining. As time goes by the number os users on our moodle site will multiply and it will become increasingly difficult to identify if someone in enrolled in the wrong course. For this reason I use the enrollment key method. If a new account is created by the 'please us more about yourself' problem then users are not enrolled in the relevant course and therefore cannot upload their assignments. If I remove the enrollment key I will still have users with multiple accounts with their uploaded assignments shared across two separate accounts which is messy for grading purposes.

          Michael de Raadt added a comment -

          Hi, Simon.

          Your screenshots look like Moodle 1.9. Am I mistaken?

          Simon Purdue added a comment -

          Yes sorry I didnt realise but we are using the 1.9.8 version

          Petr Škoda added a comment -

          Hello,

          this is most probably caused by "over_bounce_threshold()" which is triggered when user email is invalid and the messages are returned back to your server. You can either disable $CFG->handlebounces or tweak $CFG->minbounces and $CFG->bounceratio.

          In any case please upgrade you site to latest stable version, 1.9.8 is really old.

          Petr


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: