Moodle
  1. Moodle
  2. MDL-31591

Html Editor formating texts problem

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a bug
    • Affects Version/s: 1.9.15, 2.2.1
    • Fix Version/s: None
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Environment:
      Ubuntu 10.04.3 LTS
      mysql Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (x86_64) using readline 6.1
      PHP 5.3.2-1ubuntu4.13 with Suhosin-Patch (cli) (built: Feb 9 2012 06:36:10)
    • Database:
      MySQL
    • Testing Instructions:

      Add a new label.
      Type any text.
      Format it using Bold, Italic, changing color.
      Save it.
      Look to see if the format is like you set in the edit box.
      Edit it again, and save it withouyt doing any change.
      Look again to see if the format worked.

      Show
      Add a new label. Type any text. Format it using Bold, Italic, changing color. Save it. Look to see if the format is like you set in the edit box. Edit it again, and save it withouyt doing any change. Look again to see if the format worked.
    • Workaround:

      The workaround that we found out is do the downgrade of the PHP version. We did that and the bug is gone.

      Show
      The workaround that we found out is do the downgrade of the PHP version. We did that and the bug is gone.
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_22_STABLE
    • Rank:
      38154

      Description

      yesterday the Ubuntu Server updated the PHP version to PHP 5.3.2-1ubuntu4.13 with Suhosin-Patch (cli) (built: Feb 9 2012 06:36:10).
      Since then every time we edit any label and try to format any text, the format is appleid for the first time, but when you try to edit it again the label lost the format of the texts.

      And when you edit a Already formated label, and save it, it losts his format too.

      Sorry for my bad writting english.

        Activity

        Igor Lima Rodrigues created issue -
        Igor Lima Rodrigues made changes -
        Field Original Value New Value
        Priority Minor [ 4 ] Major [ 3 ]
        Nico de Boer added a comment -

        Our server runs Ubuntu too (Moodle 1.9x). I didn't research into this PHP update, but I can confirm this issue. It is more severe than only loosing the formatting of labels though. At least it affects editing forum posts, the resource "web page", and forum introductions as well (I've tested those three). I'm afraid anything you edit will not only loose it's bold/italics-formatting, but also links to URLs are mangled/removed (rendering those links useless, and forcing the user to restore them after this issue has been solved). Also single and double quotes are embellished with a backslash in front of them.

        I've warned all our users to avoid editing moodle-objects if possible, and backup first if editing is unavoidable, until this issue is solved.

        Igor Lima Rodrigues made changes -
        Workaround The workaround that we found out is do the downgrade of the PHP version. We did that and the bug is gone.
        Nico de Boer added a comment -

        The automatic upgrade to php5 version 5.2.4-2ubuntu5.23 (from 5.22) has solved the HTML-editor problems. Probably this bug can be closed now.

        Dan Marsden added a comment -

        closing as requested

        Dan Marsden made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee moodle.com [ moodle.com ] Dan Marsden [ danmarsden ]
        Resolution Not a bug [ 7 ]

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: