Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31599

Site news RSS feed doesn't work for guests

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.4, 2.3.1, 2.4
    • Fix Version/s: 2.2.5, 2.3.2, STABLE backlog
    • Component/s: RSS
    • Labels:
    • Database:
      Any
    • Testing Instructions:
      1. In Admin > Advanced features, enable RSS feeds
      2. In Admin > Plugins > Activity modules > Forum, enable rss feeds
      3. Add the latest news block to your site front page
      4. Add a news item to the front page
      5. Click to view the news item and use the settings block to edit the forum settings
      6. Enable RSS for this forum (say posts, 10 recent articles)
      7. Click the RSS link
      8. VERIFY the feed generated contains the news item you created
      9. Log out
      10. Click the RSS link
      11. VERIFY: the generated feed contains the news item you created
      Show
      In Admin > Advanced features, enable RSS feeds In Admin > Plugins > Activity modules > Forum, enable rss feeds Add the latest news block to your site front page Add a news item to the front page Click to view the news item and use the settings block to edit the forum settings Enable RSS for this forum (say posts, 10 recent articles) Click the RSS link VERIFY the feed generated contains the news item you created Log out Click the RSS link VERIFY: the generated feed contains the news item you created
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      The RSS feed link, on frontpage site news block throws an error if you are not logged in. But if you use the RSS feed directly from the forum it works fine. I´ve tested this issue on a 2.1.4 version, also you can check it on moodle.org.

        Gliffy Diagrams

          Attachments

          1. rss_error_en.png
            rss_error_en.png
            58 kB
          2. rss_error.png
            rss_error.png
            16 kB
          3. rss_moodle.png
            rss_moodle.png
            26 kB
          4. rss_moodle-org.png
            rss_moodle-org.png
            18 kB
          5. rss_OK_logged-in.png
            rss_OK_logged-in.png
            74 kB

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Thanks for reporting that.

              I'm not sure it's necessary, but it might help if you could translate the error reported.

              wenderw Wenceslao Fernadez added a comment -

              Hi

              I have updated the issue adding some more images in English.

              Salu2

              poltawski Dan Poltawski added a comment -

              Well, thanks to my former colleague Paul Verrall at LUNS, I now understand what the cause of this is. Its relating to the front page news block using 0 as the RSS feed url, rather than the siteguest.

              poltawski Dan Poltawski added a comment -

              I've fixed this, as noted the userid when not logged in needs to be the site guest rather than '0'.

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              nebgor Aparup Banerjee added a comment -

              cool, integrated into 22, 23 and master now.

              ps: some permissions testing within test here could be extra fun here.

              salvetore Michael de Raadt added a comment -

              Test result: Success!

              Tested in 2.2, 2.3 and master.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Fixed STOP Closed STOP Thanks STOP

              Yay, imagination! Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Sep/12