Moodle
  1. Moodle
  2. MDL-31600

Add 'tested with' parameter to version.php

    Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.2.1
    • Fix Version/s: BACKEND
    • Component/s: Installation
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      38163

      Description

      It seems that the only part of the process of uploading a plugin to Moodle.org that doesn't get fully filled in from version.php is the full list of versions of Moodle that it works with (only the minimum version). It would be nice if this could be automated as well. This could also be used during install to warn users if the plugin has not been tested with their version of Moodle.

      My proposed solution would be to add a 'tested with' array, containing a list of major Moodle versions.

        Activity

        Hide
        Michael de Raadt added a comment -

        Thanks for suggesting this, Davo.

        I agree that something should be done.

        I would suggest that, instead of an array of known versions, that a "latest tested" version be added, so a range could be created. I think that would be simpler to calculate and easier to automate.

        I think this should be an advisory setting, so we could work out what versions a plugin works with, rather than a restriction enforced by Moodle.

        Show
        Michael de Raadt added a comment - Thanks for suggesting this, Davo. I agree that something should be done. I would suggest that, instead of an array of known versions, that a "latest tested" version be added, so a range could be created. I think that would be simpler to calculate and easier to automate. I think this should be an advisory setting, so we could work out what versions a plugin works with, rather than a restriction enforced by Moodle.
        Hide
        Davo Smith added a comment -

        Definitely agree that it should be an advisory setting, but it would be nice if, during installation, it showed a message along the lines of 'This plugin has not been tested with your version of Moodle. It is likely to work anyway' (or something like that).

        Show
        Davo Smith added a comment - Definitely agree that it should be an advisory setting, but it would be nice if, during installation, it showed a message along the lines of 'This plugin has not been tested with your version of Moodle. It is likely to work anyway' (or something like that).
        Hide
        Marina Glancy added a comment -

        This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

        For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

        Show
        Marina Glancy added a comment - This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue. For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: