Moodle
  1. Moodle
  2. MDL-31600

Add 'tested with' parameter to version.php

    Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.2.1
    • Fix Version/s: BACKEND
    • Component/s: Installation
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      38163

      Description

      It seems that the only part of the process of uploading a plugin to Moodle.org that doesn't get fully filled in from version.php is the full list of versions of Moodle that it works with (only the minimum version). It would be nice if this could be automated as well. This could also be used during install to warn users if the plugin has not been tested with their version of Moodle.

      My proposed solution would be to add a 'tested with' array, containing a list of major Moodle versions.

        Activity

        Davo Smith created issue -
        Michael de Raadt made changes -
        Field Original Value New Value
        Fix Version/s DEV backlog [ 10464 ]
        Labels triaged
        Assignee moodle.com [ moodle.com ] Marina Glancy [ marina ]
        Marina Glancy made changes -
        Fix Version/s BACKEND [ 12582 ]
        Fix Version/s DEV backlog [ 10464 ]
        Assignee Marina Glancy [ marina ]

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: