Moodle
  1. Moodle
  2. MDL-31641

File picker drag drop help item doesn't make sense.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.3, 2.4
    • Fix Version/s: 2.3.4, 2.4.1
    • Component/s: Forms Library
    • Labels:
    • Database:
      Any
    • Testing Instructions:
      1. Using IE9 (or below) visit a forum and add a new post
        • Confirm the 'drag and drop not supported' message appears above the attachments box
        • Confirm the help text lists browsers that do support drag and drop
      2. Using Firefox/Chrome visit the same page
        • Confirm the 'drag and drop not supported' message does NOT appear above the attachments box
      Show
      Using IE9 (or below) visit a forum and add a new post Confirm the 'drag and drop not supported' message appears above the attachments box Confirm the help text lists browsers that do support drag and drop Using Firefox/Chrome visit the same page Confirm the 'drag and drop not supported' message does NOT appear above the attachments box
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull Master Branch:
      MDL-31641_drag_drop_help

      Description

      If go to the screen used to create a new forum discussion and click the help item for files (currently its next to "drag and drop available") it says, amongst other things, "Note: this may not work with other web browsers" Other web browsers? Either say this may not work in some browsers or give specific browsers.

        Gliffy Diagrams

          Issue Links

            Activity

            Davo Smith added a comment -

            'Other browsers' - in the sense of 'browsers other than the one you are currently using'. The text and the help icon do (or at least 'should') not appear at all if the current browser does not support drag and drop.

            Maybe noting specific browsers might be helpful.

            Michael de Raadt added a comment -

            It might be better to keep the message generic as support is likely to become dated quickly. Perhaps the meaning could be improved.

            Davo Smith added a comment -

            Current help string:
            You can drag one or more files from your desktop and drop them onto the box below to upload them.
            Note: this may not work with other web browsers

            Proposed replacement:
            You can drag one or more files from your desktop and drop them onto the box below to upload them.
            Note: drag and drop upload is not supported by all web browsers

            Any thoughts / other changes to this wording, before I put forward a patch for integration?

            Andrew Davis added a comment -

            Would it be worth including a link to a docs page that tells you what browsers are supported? Does such a page even exist? I couldnt find one. Also, does a link in a help popup work?

            Assuming that a link to a list of supported browsers is either actually not a good idea or doesnt work out, for whatever reason, the proposed replacement looks good

            Davo Smith added a comment -

            A quick experiment suggests that is is possible to add hyperlinks to help popups (I have no idea whether or not that is 'officially' supported, but it did work when I tried it).

            On the other hand, I can't yet access the Moodle 2.3 version of the docs.moodle.org (and these features are not available in 2.2), so I can't yet add any documentation (and it's probably a bit early to do so, as there are still some modifications in progress).

            Helen Foster added a comment -

            Davo, thanks for pointing out about MDL-37096 being a duplicate of this issue. I made the simple fix suggested by Bente, however from discussing it in the dev chat, I think the ideal solution would be to indicate to users of non-supporting-dnd browsers that the extra functionality was available and remove the help popup completely (since 'You can drag one or more files from your desktop and drop them onto the box below to upload them.' is already explained in the UI).

            Davo Smith added a comment -

            Would it make sense to add a 'drag and drop not supported' message with a help popup (to link through to the drag and drop page in the docs, which lists the supported browsers)?

            Originally, I'd come from the point of view that this was a 'bonus' feature, not always supported (to be explained when it did exist). Now I'm leaning towards it being a 'standard' feature, that should be explained when it isn't there.

            Davo Smith added a comment -

            Here is a patch that swaps the message to appear when drag and drop is NOT available, with some help text which lists common browsers that do support drag and drop upload.

            Helen Foster added a comment -

            Thanks Davo, the help text looks good to me.

            Helen Foster added a comment -

            Adding 2.4 as affects version to keep this issue current.

            Damyon Wiese added a comment -

            Hi Davo,

            Thanks for working on this issue. The patch for this issue looks good - can you please add some test instructions before we send it for integration?

            Peer review checklist:

            [Y] Syntax
            [Y] Output
            [Y] Whitespace
            [Y] Language
            [-] Databases
            [N] Testing - Needs test instructions.
            [-] Security
            [-] Documentation
            [Y] Git
            [Y] Sanity check

            Thanks!

            Damyon Wiese added a comment -

            Note to integrators - this cleanly cherry-picks to 23 - not required for 22.

            Dan Poltawski added a comment -

            Hi Guys,

            This looks good, but i'm afraid that we can't delete strings from the stable branches, so will need another patch for 2.4 and 2.3.

            The problem is that our lang packs are not versioned between minor releases, so by deleting this string if someone updated the french langpack in 2.3.3 they'd end up with a missing string (note this is also why you can't change a meaning of a string in a stable branch too).

            Its fine to remove the strings on master.

            CiBoT added a comment -

            Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

            Davo Smith added a comment -

            Here's a version for 2.3/2.4, without the string removal.

            Personally, I don't mind if this is a 'master-only' fix, but it's very small change and improves the clarity of the drag and drop a bit, so there shouldn't be any harm in it going into the earlier versions.

            Dan Poltawski added a comment -

            Thanks Davo, i've integrated this now

            Michael de Raadt added a comment -

            Test result: Success!

            Tested in Master, 2.4 and 2.3. IE9 and Safari 5 showed new message and help pop-up. Firefox and Chrome did not show this. I can't test Safari 6.

            Eloy Lafuente (stronk7) added a comment -

            And your fantastic code has met core, hope they become good friends for a long period.

            Closing, thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: