Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31653

Default setting for 'Display debug messages' is dynamic.

    Details

    • Type: Bug
    • Status: Open
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: 2.2.1
    • Fix Version/s: STABLE backlog
    • Component/s: Administration
    • Labels:
    • Environment:
    • Workaround:
      Hide

      Not really needed but I'm not sure of the impact of the code.

      Show
      Not really needed but I'm not sure of the impact of the code.
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      The default value for 'Display debug messages' in Site Administration->Development->Debugging changes to whatever the value of the tick box is upon refresh.

      Replication steps (from screenshot):

      1. Log in as admin
      2. Navigate to Site admin > Development > Debugging
      3. If the setting "Display debug messages" is unchecked, check it, save settings and click Debugging in the Settings block
      4. Uncheck (untick) the "Display debug messages" option
      5. Save changes to the form
      6. Click on Debugging again in the Settings block
      7. Note change to default value

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: