Moodle
  1. Moodle
  2. MDL-31678

Sometimes site menu items don't open (expand) on mouse click

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.1, 2.3.1, 2.4.3
    • Fix Version/s: None
    • Component/s: Accessibility, Navigation
    • Labels:
    • Environment:
      1) Linux Debian 6.0.4, nginx 1.0.12, MySQL 5.1.49-3, PHP 5.3.3-7
      2) Linux Debian 6.0.5, nginx 1.2.3, MySQL 5.1.61, PHP 5.3.3-7+squeeze9
      3) Linux Debian 6.0.7, nginx 1.4.0-1-squeeze, MySQL 5.1.66-0+squeeze1, PHP 5.3.3-7+squeeze15
    • Database:
      MySQL
    • Testing Instructions:

      Tested in Moodle 2.2.1+, build 07.02.2012. Problem detected in the following Windows web browsers: Google Chrome ver. 17.0.963.56 m, Firefox 10.0.2, Opera/9.80 (Windows NT 6.0; U; en) Presto/2.10.229 Version/11.61, Explorer 9.0.8112.16421, Safari 5.1.2 (7534.52.7). Usually it's possible to reproduce the problem by manually reloading the web page (clicking "Reload" button in web browser). When clicking the grey menu items, e.g. "Administration" menu item - nothing happens. The menu item is supposed to expand. Complete list of tested MOODLE versions:
      1) Moodle 2.2.1+, build 07.02.2012
      2) Moodle 2.3.1+ stable, version 2012062501.11, build 20120823.
      3) Moodle 2.4.1+ stable, build 20130418.

      Show
      Tested in Moodle 2.2.1+, build 07.02.2012. Problem detected in the following Windows web browsers: Google Chrome ver. 17.0.963.56 m, Firefox 10.0.2, Opera/9.80 (Windows NT 6.0; U; en) Presto/2.10.229 Version/11.61, Explorer 9.0.8112.16421, Safari 5.1.2 (7534.52.7). Usually it's possible to reproduce the problem by manually reloading the web page (clicking "Reload" button in web browser). When clicking the grey menu items, e.g. "Administration" menu item - nothing happens. The menu item is supposed to expand. Complete list of tested MOODLE versions: 1) Moodle 2.2.1+, build 07.02.2012 2) Moodle 2.3.1+ stable, version 2012062501.11, build 20120823. 3) Moodle 2.4.1+ stable, build 20130418.
    • Workaround:

      The first workaround is to clear browser cache and Refresh the page. Actually, "Refresh" and "Reload" the page - are 2 different actions! You can reload the page using F5, refresh - using Control+F5. In last case the browser's cache cleans and the full page loads successfully. So it seems that the problem is related to incorrect caching of the web page objects. It's the nature of the problem. Incorrect loading/functioning of JavaScript is the aftermath. After the problem was solved I added settings to web server configuration that change the Cache-Control header of the web page so that it prevents the browser from caching it. I added the following parameters to Cache-Control:
      no-store, no-cache, must-revalidate, post-check=0, pre-check=0

      Such modification works on all browsers I tested and now my Moodle works fine and stable without menu problems! But of course such solution is temporary and completely turns off cache. So it results in degrade of Moodle's loading speed, efficiency and performance.

      Show
      The first workaround is to clear browser cache and Refresh the page. Actually, "Refresh" and "Reload" the page - are 2 different actions! You can reload the page using F5, refresh - using Control+F5. In last case the browser's cache cleans and the full page loads successfully. So it seems that the problem is related to incorrect caching of the web page objects. It's the nature of the problem. Incorrect loading/functioning of JavaScript is the aftermath. After the problem was solved I added settings to web server configuration that change the Cache-Control header of the web page so that it prevents the browser from caching it. I added the following parameters to Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Such modification works on all browsers I tested and now my Moodle works fine and stable without menu problems! But of course such solution is temporary and completely turns off cache. So it results in degrade of Moodle's loading speed, efficiency and performance.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Rank:
      38254

      Description

      After login (administrator rights) the menu has 2 types of items: blue ones (classic links) and grey ones (with triangle symbols on the left that are supposed to expand on click). The problem is that grey items don't expand on click. Absolutely nothing happens when you click the grey menu items. Turning on/off the use of external YUI libraries (useexternalyui) doesn't solve the problem.

      1. caching.jpg
        347 kB
      2. Capture.PNG
        12 kB
      3. Moodlemenubug.png
        70 kB
      4. ramil_site.20120911.png
        289 kB
      5. screenshot.jpg
        149 kB
      6. tulpar.png
        133 kB

        Issue Links

          Activity

          Mike Thomes added a comment -

          I have the same issue except that this issue happens ALWAYS not sometimes.

          Gabriel Stan added a comment -

          I have the same problem.

          Mike Thomes added a comment -

          I have resolved this issue for my Moodle site.

          After a lot of investigating I found that for me it was that I had a wordpress security plugin on my hosting environment which had changed the .htaccess file and this prevented me from interacting with the moodle site admin menu and also from having permission to view some moodle pages.

          Gabriel Stan added a comment -

          Can you please tell us if there's something we need to change in .htaccess? Or can you please offer some details on how to go about checking if .htaccess is causing the problem?

          Gaurav added a comment -

          I have used the workaround but still menu doesn't open up on mouse click.

          Gaurav added a comment -

          Even after clicking the arrow signs i am not able to expand the menues.

          Erasmo Carlos de Oliveira added a comment - - edited

          I'm having this problem is unfortunately not yet managed to solve ...
          Mike Thomes, what you changed in HTACCESS to open the menu ...
          Gaurav, what is the solution to expand the menus alternatica administration?

          Erasmo Carlos de Oliveira added a comment -

          I'm having this problem is unfortunately not yet managed to solve ...
          Mike Thomes, what you changed in HTACCESS to open the menu ...
          Gaurav, what is the solution to expand the menus alternatica administration?

          Troy Shimkus added a comment -

          Working on a fresh install of everything, a brand new server just delivered, fresh yum install of PHP, MySQL. Installed Moodle from Git.
          Experiencing this problem now.
          I've noticed using Firebug that not all of the script files are loading properly, and not all of the image files are loading properly. I would suggest checking with those on your systems and then, as I'm about to do, verify and check permissions on folders.

          Kenny McCormack added a comment -

          We have been able to reproduce the same problem on Moodle 2.1.5+ (Build: 20120405) but only when using Japanese language - English is OK. The suggested workaround has no improvement affect.

          Sam Hemelryk added a comment -

          Hi guys, just chiming in here.

          The navigation + settings expansion stops working if JavaScript breaks.

          It could be because there is a JavaScript error in code before the navigation+settings JS, or it could be because some or all of the JavaScript required for the page could be loaded.
          It could be any JS as well, not just the JS relating to the navigation+settings expansion. Most browsers stop processing all JS if there is a single uncaught JS error.

          I would suggest using either Firefox or Chrome and checking the JavaScript error logs (normally Ctrl + J) and seeing if there is anything there.
          The console provided by Firebug, or Chromes developer tools can also help as they normally show when a resource can't be loaded.

          Just two more things to think about/try if you are experiencing these problems.
          If you do find a JS error then please create a new bug with specifics about it, giving as much detail as you can will help.

          Cheers
          Sam

          Ramil Valitov added a comment -

          Dear Sam
          yes, there are problems with JavaScript that are detectable by Firebug or other stuff, actually Troy is more correct - the probllem is that not all JavaScript files load properly or in proper order. But it's still the aftermath of the real problem. The problem is in caching. I updated this ticket with more information and workaround.

          Brian King added a comment -

          On 2.3.1, I notice that this happens when I a try to access a course which requires an enrolment key, and I'm not yet enrolled.

          There's a javascript problem in this section of javascript:
          (elipses inserted for brevity)

          YUI.add('moodle-form-passwordunmask', function(Y) {
          ...
                  add_checkbox : function(elementid, checkboxlabel) {
                      var node = Y.one('#'+elementid);
          ...
                      //Insert unmask div in the same div as password input.
                      node.get('parentNode').insert(unmaskdiv, node.get('lastNode')); // this is the line where it fails
                  }
          }
          

          The reported javascript error is "Uncaught TypeError: Cannot call method 'get' of null".

          Kenny McCormack added a comment -

          The issue seems to be cause by the PHP version -> 5.3.14 in our case.

          We traced the issue to a problem with the PHP function json_encode() and correlated the timing of reporting of the problem when we upgraded our PHP version.

          Upgrading to 5.1.15 resolved the problem - json_encode() incorrectly truncates/discards information

          https://bugs.php.net/bug.php?id=61537

          I hope that helps

          Kenny McCormack added a comment -

          Another note on this issue it also caused personal system messages send from person to person not to be notified as a popup

          David Monllaó added a comment -

          Hi,

          As Sam commented this issue was caused by some broken JS, I've tried to reproduce the reported problem in the described environment with the latests stable releases 2.2, 2.3 and 2.4 (in development) but I've been unable to reproduce it. Looking at the tracker I've seen many broken JS related issues, probably the JS problem related with this issue was solved by another issue; please, can some of you verify that the problem still exists? I'm adding myself as a watcher just in case someone finds something, otherwise we can close the issue. Thanks in advance

          Kenny McCormack added a comment -

          Hi David,

          As per my last posts on the issue the problem seemed be caused by the actual PHP version on the Moodle environment hosting platform in part, at least for us.

          Once we upgraded the PHP version at the server level it resolved the issue with exception of Internet Explorer 9 and only turning on the developer tools resolved the issue - so I would expect this IE issue is another unrelated JS problem given that is client based. We will be upgraded the customer's site from 2.1.5 to 2.3 very shortly so will review then if the issue on IE still remains

          Best Regards,

          Kenny

          Ramil Valitov added a comment -

          Hi David,
          thank you for your time and assistance!
          I have my platfrom upgraded to 2.3+
          I'll check the problem again and post the results shortly.

          Ramil Valitov added a comment -

          Hi, David.
          I turned off Cache-control. The problem still exists. Now I use MOODLE 2.3.1+ stable, version 2012062501.11, build 20120823. My software has also been upgraded: Linux Debian 6.0.5, nginx 1.2.3, MySQL 5.1.61, PHP 5.3.3-7+squeeze9.

          If you'd like, I can create a dedicated MOODLE site on my servers, and grant you all the access you need for the test purposes.

          Ramil Valitov added a comment -

          A new attachment-screenshot shows how the site becomes visible in MOODLE 2.3.1+ when Cache Control is turned off.

          Michael Arguin added a comment -

          I have run into the same problem. Upgraded PHP to 5.3.16, cleared caches in theme, browser and moodle server. Set $CFG->filelifetime = 0; NONE of this worked. What did appear to work is to Set XML strict headers to True in the Debugging settings. Don't know if this additional information will help or not but thought it was worth reporting.

          David Monllaó added a comment -

          Hi, thanks all of you for your replies and the efforts to solve this issue

          To replicate the problem it could be helpful if you can reply with the settings you are using when you experience the problem, to be more specific:

          • Site administration -> Appearance -> AJAX and Javascript: useexternalyui, cachejs and yuicomboloading
          • Site administration -> Appearance -> Themes: themedesignermode
          • CFG->filelifetime or other significant non-default settings that can have something to do with caching or Javascript

          It will also be good for me to see the Javascript error you are receiving. If you have any problem sharing this info or the settings in use send me the details privately, thanks.

          Adding to the possible moodle-scope issues:

          • Have you checked if Nginx or any other web proxy or load balancer that you are using could have something to do with the problem?
          • Can you reproduce the problem in a clean moodle site? As "clean" I would mean a site without extra 3rd party plugins nor themes

          Ramil, in case that I can't reproduce the problem with this info I'll ask you privately about the access, thanks again

          Ramil Valitov added a comment -

          Hi, David!
          I have a dedicated site for you with the settings when the problem is experienced. It's a standard clean latest MOODLE 2.3.1+ install without 3rd party plugins. You're assigned as a site administrator, so you can do all the tests you need and configure the site as you need. The site address is: demo.kfu-elearning.ru English language is installed. User name and password was sent to your e-mail address that was set in your forum profile.

          About the moodle-scope issues:
          1) sure I checked nginx, we have different web projects running at the server (e.g. sites, Joomla, etc.), we experience such problems only with MOODLE.
          2) yes, the problem can be reproduced in clean site.

          Mary Evans added a comment - - edited

          I have had this happen when I use certain jQuery scripts. I forget which one other than it was minified.

          David Monllaó added a comment -

          Thanks for the comments Mary, your issues with JQuery probably were related with JS conflicts; isolating this issue it seems more a caching issue than a JS issue since there are also CSS related problems

          David Monllaó added a comment -

          Hi Ramil,

          I've done some tests in the provided environment, purging cache after each settings change, I've found that:

          • With useexternalyui enabled all works as expected
          • The cachejs setting value is not important
          • yuicomboloading is the problem
            (remember to purge cache after each settings modification to replicate the scenarios)

          I've attached a screenshot with the chrome code inspector warnings (cachejs off + yuicomboloading on) It seems there is a problem with how nginx is serving the files but I can not help you with that, I hope it helps you to solve the problem

          David Monllaó added a comment -

          Hi,

          I'm closing this issue as cannot reproduce since it's related with systems issues instead of a moodle problem, but I'll be watching it just in case someone can provide more info that points to a possible solution on the moodle-side. Thank you all for your efforts

          Donna Smith added a comment - - edited

          Just had the same problem as we migrated sites from one server to another. We moved 3 Moodle instances, two at 2.2.4 and one at 2.2.5. The Moodle version 2.2.5 had this problem. After reading this case, researching, and time, I found it to be the YUI online libraries and combo loading. After first checking YUI online libraries, still no luck. Unchecked, combo loading, some response but then nothing. Unchecked both, still nothing. Checked both, and PRESTO it worked. So this is STILL definitely a bug in Moodle 2.2.5.

          Go to the SEARCH button under Site Administration and type in YUI, it will take you to the needed screen. I hope this helps someone from all the time I spent on it.

          François Lizotte added a comment -

          Same issue here too. We are dealing with 50 instances of Moodle. The problem is reported on one of them (version 2.2.6) by admin users. I cannot reproduce it but two of my colleagues (admin) have it. We all run on the same Firefox version.

          It worked after unchecking yuicomboloading. I checked it again and unchecked it and the bug is still there.

          Donna Smith added a comment -

          Try checking the comboloading and the online libraries. This combination worked for me. I have no idea what checking online libraries will do to the rest of the site, but so far so good.

          Sheryl Villaroman added a comment - - edited

          Thanks Donna Smith, checking both "Use online YUI libraries" and "YUI combo loading" solves the problem.
          At first, I had a suspicion that the problem has something to do with the cache and JavaScript matters, and far that I have known that it will be resolved and has something to do with online CSS and JavaScript libraries. I thought that it won't work "checking both the use of external YUI libraries" as stated on the description above, but it does solve the problem on my end.

          Ramil Valitov added a comment -

          I upgraded MOODLE 2.4.x to the latest stable release. And run the test again. Unfortunately for me checking both "Use online YUI libraries" and "YUI combo loading" DOESN'T solve the problem! I still have to alter parameters in my webserver (nginx) for Cache-Control:
          no-store, no-cache, must-revalidate, post-check=0, pre-check=0

          Ramil Valitov added a comment - - edited

          I made further tests. I attached a screenshot that shows the warnings of MIME type problems like this:
          Resource interpreted as Image but transferred with MIME type text/plain
          Resource interpreted as Script but transferred with MIME type text/plain
          Resource interpreted as Stylesheet but transferred with MIME type text/plain

          And we can see links like this:
          theme/styles.php/nonzero/1346316648/all
          theme/javascript.php/nonzero/1346316648/footer
          theme/image.php/nonzero/core/1346316648/help

          The problem is that browser doesn't get the files above, because they don't exist. I don't have a folder named "1346316648" in my "theme/nonzero" folder. Is it a bug? Why I don't have this folder and the required files in it? Does anybody have such folders in "theme/nonzero" directory? Please, your awnsers may help me to find the solution!

          Ramil Valitov added a comment -

          Some more information. When I open something like "theme/styles.php/nonzero/1346316648/all" - the file is being taken from MOODLE cache folder. I can read the HTTP header of the response:
          Date: Sat, 20 Apr 2013 19:28:03 GMT
          Cache-Control: public, max-age=5184000
          Server: nginx/1.2.8
          Etag: e9fcc91c3293d4fec572dff6d076d7575ac64ea4
          Expires: Wed, 19 Jun 2013 19:28:03 GMT

          200 OK

          But the file contents is empty. Any suggestions?

          Thang added a comment -

          Hi,
          Has anyone solved this problem yet? I've tried everything but still failed. I tried running on the local normal.
          Who can help me, thank you very much.
          P/S: Sorry, my english is not good.

          Thang added a comment -

          Hi,
          Has anyone solved this problem yet? I've tried everything but still failed. I tried running on the local normal.
          Who can help me, thank you very much.
          P/S: Sorry, my english is not good.

          Ramil Valitov added a comment -

          Hi, Thang!
          What web server and OS do you use?
          I didn't have any problems with Apache 2.2 and Apache 2.4 installed with default configuration under Windows.
          I had problem with nginx under Linux. The solution I have is to turn off caching in configuration of web server. I use the following modification to parameters of Cache-Control:
          no-store, no-cache, must-revalidate, post-check=0, pre-check=0
          Such modification can be applied to any web server (read manual for your web server).
          Anyway, please, leave your awnser to my question above and comments if the solution helped you or not. Good luck!

          Ramil Valitov added a comment -

          FOR MOODLE TEAM:
          I can give you a complete access to a dedicated (non-production) web server for any kinds of testing. I can make a clean install of any version of MOODLE at my server. I'm very eager and open for cooperation:
          1) I can install and configure the environment on your server, so you can test your code in nginx (forever).
          2) I can install and configure the environment on my server give you a dedicated web server (web hosting) for testing (forever).
          3) I can assign some web developers from my team that can help you (under your guidance and leadership) coding to fix the problem.

          As a major university of Russian Federation that uses MOODLE more than others in our country we're very interested in solving this problem and different types of cooperation/partnership.

          Thang added a comment -

          Hi, Ramil!
          Thank you very much, I turned off Cache JavaScript and this job was successful.
          I'm very grateful for your support!

          Ramil Valitov added a comment -

          Thang, you're welcome!
          I'm glad that my workaround helped you! Please, click the "Vote" button on the top-right side of the screen to make the MOODLE team pay attention to this issue and fix it in next MOODLE releases. Thank you in advance and good luck!

          Thang added a comment -

          I would like to do this, but unfortunately I have not been allowed to use the "Vote".

          Terris Foley added a comment -

          I have recently installed moodle 2.4 on a Windows 2008 Server running IIS 7, MySQL 5.5 and PHP 5.3. The moodle install completed successfully, however I am experiencing the same issues with site menu items not expanding and remaining in a greyed-out status. I have read most post here and have disabled the output caching elements in IIS Manager to include .js extensions which has served to no avail. I see that the Cache-Control is a viable way to resolve this issue, how do I create the Cache-Control and where will this code reside?

          Cache-Control:
          no-store, no-cache, must-revalidate, post-check=0, pre-check=0

          Your help is greatly appreciated

          Ramil Valitov added a comment -

          Dear Terris,
          may be this can help you:
          http://support.microsoft.com/kb/247404/en
          If not, you're welcome to use Google!
          Good luck and please leave comment if my solution with Cache-Control helped you!
          If you have any other questions, just ask, I'll try to help you.

          Heribert Schmidt added a comment -

          I've had the same Problem (Moodle 2.5). That solved the Problem:

          Donna Smith wrote "Checked both, and PRESTO it worked. So this is STILL definitely a bug in Moodle 2.2.5.

          Go to the SEARCH button under Site Administration and type in YUI"

          After that I had to:

          Ramil Valitov Wrote: " You can reload the page using F5, refresh - using Control+F5. In last case the browser's cache cleans and the full page loads successfully."

          Also disabeling JavaScript (FireFox) worked for me, but this was not a satisfying solution because there were no more graphics in the menues and they were all expanded.

          Many thanks to Donna and Ramil. I think we all finaly hope for a solution from the developers .

          Mark Watson added a comment -

          This problem occurs in Moodle 2.5.1 as well.

          Mark Watson added a comment -

          I might add that I have to disable Javascript in ALL browsers.

          Mark Watson added a comment -

          I have tried all suggestions re this problem of menu items not opening and nothing worked apart from disabling JAvascipt which is a poor option. JAvascript leaves the menus all expanded and in some themes (eg darkb) you cannot scroll far enough down to get at all the menus.

          I decided to revert to v2.4 on the same system - the menu problems does not occur.
          Surely this is a Moodle v2.5 issue!

          Antonio Piedras Morente added a comment -

          This problem also occurs in Moodle 2.4.4. The application don't work because you can not display the menu options or to add resources or activities.
          One solution we have found is purge all cache. With this the application works again, but we don't know what is the reason of this problem.

          Goutam added a comment -

          foll solved my prob (ver 2.4.6+)
          enable ajax - tick
          use online you libraries- untick
          yui combo loading: tick
          cache javascript : untick

          also in appreance section:
          theme designer mode:tick

          Ramil Valitov added a comment -

          Thank you, Goutam! But activating the "Theme designer mode" significantly degrades performance and not intended to be used on production sites. Yet, I'm glad this problem still occurs but the ticket is closed.


            Dates

            • Created:
              Updated:
              Resolved: