Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31756

group of mform elements display badly whether label is empty

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: Administration
    • Labels:
      None
    • Testing Instructions:
      Hide

      Set theme to standard
      Copy the attached file to your moodle root folder.
      Call it with: http://<<yourserver>>/HEAD/demo_err.php

      Show
      Set theme to standard Copy the attached file to your moodle root folder. Call it with: http://<<yourserver>>/HEAD/demo_err.php
    • Workaround:
      Hide

      replace the empty $label with

      '&nbsp;'

      Show
      replace the empty $label with '&nbsp;'
    • Affected Branches:
      MOODLE_23_STABLE

      Description

      Set theme to standard
      Copy the attached file to your moodle root folder.
      Call it with: http://<<yourserver>>/HEAD/demo_err.php

      You will se a very simple mform well diplayed.

      Now edit the code and uncomment line 13 so that $label = ''

      Call the page again.

      As you can see while the first select is always displayed in the right place, the group element slither on the left.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              rajeshtaneja Rajesh Taneja
              Reporter:
              daniss Daniele Cordella
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: