Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.7, 2.1.4, 2.2.1, 2.3
    • Fix Version/s: 2.3
    • Component/s: Hub
    • Labels:
    • Testing Instructions:

      1) check that on Admin > Notification page a warning is displayed notifying that your site is not registered on Moodle.org. Check that the link goes to Moodle.org registration form. Check all make sens to you.
      2) check that the Admin > Registration page goes to the same Moodle.org registration form.
      3) Check that on Admin > Server > Hubs there is a message saying that you need to be registered on Moodle.org to register on MOOCH. Also check that the link redirects to Moodle.org registration form.

      If possible try to register on Moodle.org (your test site must be reachable from Moodle.org server) and check that the warnings disappeared.

      Show
      1) check that on Admin > Notification page a warning is displayed notifying that your site is not registered on Moodle.org. Check that the link goes to Moodle.org registration form. Check all make sens to you. 2) check that the Admin > Registration page goes to the same Moodle.org registration form. 3) Check that on Admin > Server > Hubs there is a message saying that you need to be registered on Moodle.org to register on MOOCH. Also check that the link redirects to Moodle.org registration form. If possible try to register on Moodle.org (your test site must be reachable from Moodle.org server) and check that the warnings disappeared.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      MD-31803
    • Rank:
      38421

      Description

      The current registration process is known to be confusing. People don't know Mooch and don't understand that it is in fact the Moodle.org registration that allow to get security information by email or to get listed on Moodle.org if desired.

      The idea to mention Mooch was to make admins aware of its existence. And so it would encourage teachers to share their course with the community (if capability enabled).

      I suggest the following improvements:
      1- when the admin click on Admin > Registration, the page displays the registration form. The admin changes the fields if he wants then click the Register button. A new admin page is displayed saying that the registration is successful.
      2- move "register on specific hub" button on a different page. For example it could be Admin > Courses > Register on a hub. On this page, as a reminder, we can detect if the site is not registered to Moodle.org and indicated: "To publish on MOOCH you must first register on Moodle.org" - being a link to the registration form page.
      3- on the "Add a course" page, we should add a button 'Add a existing course from a hub'.
      4- in the Admin > Notification we should always remind admin when the site is not registered on Moodle.org.

        Activity

        Jérôme Mouneyrac added a comment -

        1- has been implemented.

        Jérôme Mouneyrac added a comment -

        Sending to Helen for peer-reviewing the two lang files.

        Helen Foster added a comment -

        Jerome, thanks a lot for working on this issue. Your changes so far seem great to me! Here are a few language string suggested improvements:

        1. Notifications page admin/index.php

        Change registrationwarning to 'Your site is not yet registered.' then have a button (more noticeable than a link within text) 'Register your site'. Clicking the button takes you to the registration page.

        2. Registration page

        Change the lang string registermoodleorg to

        When you register your site with moodle.org

        • You are added to a low-volume mailing list for important notifications such as security alerts and new releases of Moodle
        • Statistics about your site will be added to the statistics of the worldwide Moodle community http://moodle.org/stats/
        • Your site is also registered with the Moodle.org Open Community Hub (MOOCH)

        (Bullet points are easier to read, first bullet point is I think the main reason why people decide to register, last bullet point explains MOOCH connection.)

        3. Hubs page admin/registration/index.php

        I notice Settings > Site administration > Server > Registration is now Settings > Site administration > Server > Hubs which I think is much better than before, as it was confusing having 'Registration' twice in the site admin settings menu.

        As MOOCH is a hub, I think it should be listed either in 'Register with a hub' or as 'Registered with'. Perhaps add the text 'Note: When you register your site with moodle.org, your site is also registered with the Moodle.org Open Community Hub (MOOCH).'

        One last small suggested lang string change: change registeredon to 'Hubs with which you are registered'.

        Jérôme Mouneyrac added a comment -

        sent for peerreview

        Jérôme Mouneyrac added a comment -

        Before sending to integration don't forget AMOS !!! (msg to mysefl)

        Rossiani Wijaya added a comment -

        Hi Jerome,

        I noticed the following error:

        Notice: Undefined variable: registerbutton in /master/admin/renderer.php on line 499 

        Minor issue on spacing:

        • admin/registration/forms.php line 239 – $emailalert = ($emailalert === 0)?0:1;
        • admin/registration/index.php line 187 – array('huburl' => HUB_MOODLEORGHUBURL

        comments on admin/registration/index.php:

        • remove the word 'with' from "On this page the administrator selects with which hub he wants....."
        • typo for the word 'also' – "On this page the administrator can alse unregister..."
        • you might want to rephrase the comments and make it clearer.

        Other than that, it looks good.

        Jérôme Mouneyrac added a comment -

        Thanks Rosie, submitting for integration.

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Dan Poltawski added a comment -

        Hi Jerome,

        I'm reopening this because a little birdie said to me:
        "Before sending to integration don't forget AMOS !!! (msg to mysefl)"

        :-P

        However, I am also slightly nervous of this landing for 2.3, if you think that this really must make it then please fix that up and submit and ping me. Then the integrators will discuss it to decide.

        Jérôme Mouneyrac added a comment -

        Argh, I remember writing two line of AMOS code for this issue. I must have lost it in a later push...

        Jérôme Mouneyrac added a comment -

        Rebased, fix conflicts and added disappearing AMOS. You can integrate it

        Dan Poltawski added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Dan Poltawski added a comment -

        Hi Jerome,

        Thanks, I've integrated this now. I made a few notes in the integration:

        1. Its a shame the /admin/ needs to do registered = $DB->count_records('registration_hubs', array('huburl' => HUB_MOODLEORGHUBURL, 'confirmed' => 1)) rather than examine an entry in the config table (which doesn't take a db query)
        2. There are two comments saying: //do not check sesskey if confirm = false because this script is linked into email message - both of them look inaccurate/ misleading to me?
        3. (To helen too). 'Your site is also registered with the Moodle.org Open Community Hub (MOOCH)' sounds a bit scary to me. Will all my courses appear on mooch if I click this button? I can imagine that sentence could put people off. Maybe we need to explain what that means.
        Helen Foster added a comment -

        Hi Dan,

        Thanks for your comments. Good point about that sentence sounding rather scary! How about changing it to:

        Your site is also registered with the Moodle.org Open Community Hub (MOOCH), allowing users with the publish courses capability (by default only managers) the option of publishing courses to MOOCH.

        Dan Poltawski added a comment -

        Thanks Helen, i've pushed a new commit with your suggested terminology. (Tester you will need to purge caches to see it).

        Ankit Agarwal added a comment -

        works as expected.
        Passing
        Thanks

        Eloy Lafuente (stronk7) added a comment -

        We could celebrate it today... but better if we perform a bigger party after releasing Moodle 2.3.

        Print this message and come to Perth that day, it's valid for one beer, wine, coke or... water, as you wish.

        Many thanks for your collaboration!

        Ciao


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: