Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31823

Profile field "confirmed" set to 0 for roaming users created via mnet course enrolments

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.17, 2.1, 2.2
    • Fix Version/s: 1.9.19, 2.1.7, 2.2.4
    • Component/s: MNet
    • Labels:
      None

      Description

      Related to http://tracker.moodle.org/browse/MDL-27107 and http://tracker.moodle.org/browse/MDL-29991 (I can't reopen issues) the MDL-27107 and MDL-29991 patches only solves the problem when users are created into the remote host via login (auth/mnet), when users are created through the remote course enrolment process (enrol/mnet/enrol.php/enrol_user method) the users are created with 'confirmed' = 0

      Steps to reproduce the problem:
      1.- A Moodle 1.9 installation as identity provider publisher
      2.- A Moodle 2.1 installation as identity provider subscriber
      3.- On Moodle 1.9 go to frontpage administration block -> Networking -> Enrolments
      4.- On Moodle 1.9 select the 2.1 subscriber host and enrol users (IMPORTANT: Users who doesn't exists in the 2.1 installation)

      Result:
      Users created on the Moodle 2.1 installation with the 'confirmed' field set to 0. If the Moodle 2.1 administration setting 'deleteunconfirmed' is enabled the cron will delete the no-confirmed users.

      The reproduction steps are based on a real case, but watching both 1.9 and 2.x code I suspect that the problem is applicable to all branches

        Gliffy Diagrams

          Activity

          dmonllao David Monllaó added a comment -

          Pull branches rebased

          mudrd8mz David Mudrak added a comment -

          Very well spotted and patched David! Submitting for integration.

          poltawski Dan Poltawski added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          dmonllao David Monllaó added a comment -

          Thanks Dan. Done

          samhemelryk Sam Hemelryk added a comment -

          Thanks David and David, this has been integrated now

          ankit_frenz Ankit Agarwal added a comment -

          Thanks Sam and Apu for the help with testing
          This works as expected.
          Passing

          stronk7 Eloy Lafuente (stronk7) added a comment -

          We could celebrate it today... but better if we perform a bigger party after releasing Moodle 2.3.

          Print this message and come to Perth that day, it's valid for one beer, wine, coke or... water, as you wish.

          Many thanks for your collaboration!

          Ciao


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                9/Jul/12