Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-31888

Scroll bars appear when displaying SCORM package in 2.2.1+

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.3
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      Add new SCORM activity.
      Upload test scorm package (Presentation1.zip attached).
      Set display to within current window.
      View SCORM package
      Also test with display set to new window.

      Show
      Add new SCORM activity. Upload test scorm package (Presentation1.zip attached). Set display to within current window. View SCORM package Also test with display set to new window.
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      master_MDL-31888

      Description

      Since upgrading from 2.1.4 to Moodle 2.2.1+ (Build: 20120223), both vertical and horizontal scroll bars appear when displaying SCORM packages in either the current window or new window. See attached screenshot.

      It occurs with FF 10.02, Chrome 17. In IE 8 there are no scroll bars but the browser window appears unhappy - being resized from full screen to smaller for no apparent reason.

      Also occurs with standard theme. Also occurs with all our currently published packages that previously displayed fine.

      SCORM created in Articulate '09.

        Gliffy Diagrams

          Attachments

            Activity

            lazydaisy Mary Evans added a comment - - edited

            @Dan
            Just learned today in this forum discussion...

            http://moodle.org/mod/forum/discuss.php?d=197444&parent=861968

            ...that by adding the following CSS...

            .yui-layout-scroll div.yui-layout-bd{overflow:visible;}

            ...fixes this bug.

            If this is so, perhaps this fix could go into mod/scorm/styles.css which in turn should override YUI CSS.

            I can do this if it helps?

            What do you think?

            Cheers
            Mary

            danmarsden Dan Marsden added a comment -

            haven't tested this so pushing it through for peer review - Mary is this something you can check? - thanks!

            lazydaisy Mary Evans added a comment -

            I'll take it for a test drive...and let you know how I get on.
            Cheers
            Mary

            lazydaisy Mary Evans added a comment -

            @Dan

            Works OK...

            danmarsden Dan Marsden added a comment -

            thanks Mary - submitting for integration!

            danmarsden Dan Marsden added a comment -

            NOTE TO INTEGRATOR: 22Stable and master only - NOT 2.1 - thanks.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Some hours ago...

            the main moodle.git repository has been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Thanks guys, this has been integrated now

            skodak Petr Skoda added a comment -

            very interesting solution, I guess it might be used in resource modules too

            if this was a contrib plugin it would be better to bump up version.php after any JS, CSS or lang change, but it does not really matter for core modules

            tested in Safari, FF and Chrome

            in IE10prev and IE9 it does funny things - the browser window resizes and jumps around, but I guess it is not caused by this patch, so passing test...

            andreabix Andrea Bicciolo added a comment -

            Hi all,

            thanks for your test on this solution, I'm glad to know it works in FF Safari and Chrome: Do you think something could be done also for IE9 (and IE8, if suffers the same problem too) ?

            Thanks,
            Andrea

            skodak Petr Skoda added a comment - - edited

            I do not know what is causing this IE trouble or how to resolve it, sorry. Please create new issue if necessary, it would be good to first test resizing in mod/url or mod/resource too (it is using a bit different code I guess).

            I am going to test some different scorm package now...

            skodak Petr Skoda added a comment -

            confirming, the jumping does not happen with other scorm package from http://scorm.com/scorm-explained/technical-scorm/golf-examples/ (1.2 example)

            andreabix Andrea Bicciolo added a comment -

            Hi Petr, which versions of IE you used for testing ?

            lazydaisy Mary Evans added a comment - - edited

            Not sure if this is relative to this but whenever testing in IE it is always worth checking that you are not in Compatibility Mode. You can do this by clicking F12 (Function Key 12) this shows you the various options you can view the page in.

            In my experience designing Moodle themes, the changes in IE tend to be because of the browser switching from normal view to compatibility.

            There are some instances, particularly with some course format plugins, that throw a Moodle page into Quirks mode, this is because the course format plugin had saved files with UTF8-BOM added to it.

            Like I said this might not be relative, but it's always worth checking IE9 & IE10 with F12.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            FCT (fixed, closing, thanks). Ciao

            "I feel a very unusual sensation - if it is not indigestion, I think it must be gratitude!"
            ~ Benjamin Disraeli

            farnaws Nawshad Farruque added a comment - - edited

            We are still having this issue in google chrome. The version we are finding this problem is moodle 2.7.3+ and Chrome Version 39.0.2171.71 m. :Latest version of FF and IE is good.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/May/12